1940 Chevy 216 waterpump - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 01-26-2012, 10:38 AM
Registered User
 
Join Date: Sep 2011
Location: 47562
Posts: 5
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
1940 Chevy 216 waterpump

Does anyone have a picture of a 216 waterpump with the impeller cover removed? My 216 runs hot too. Someone told me the impeller looks like it is on backwards. I know when the t-stat opens up, the water in the radiator moves very slow.

    Advertisement
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1940 chevy headlites on 1939 Chevy Carpoor Body - Exterior 2 04-26-2011 10:13 PM
chevy short snout waterpump Smokeytires Engine 1 04-10-2010 07:27 PM
5" waterpump bolt (Ford 289) head broke off and frozen in waterpump ccarccrazy Engine 6 07-14-2006 02:31 PM
SB Chevy Waterpump Mike&Pat Engine 3 03-28-2006 07:53 AM


All times are GMT -6. The time now is 05:31 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.