Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Garage - Tools (http://www.hotrodders.com/forum/garage-tools/)
-   -   1964 Ingersoll Rand T30 compressor restore... (http://www.hotrodders.com/forum/1964-ingersoll-rand-t30-compressor-restore-219516.html)

Steel 05-17-2012 03:11 PM

1964 Ingersoll Rand T30 compressor restore...
 
I picked up this compressor for $100. Did a total restore on this minus the pump since it was rebuilt only a few years ago and was sitting ever since. Add a new Baldor 240v 1ph motor, AB motor starter and viola!! Love this damn thing, it's a huge upgrade over my Craftsman compressor. Here are a few pics of the restore:

http://i182.photobucket.com/albums/x...7/992e66e3.jpg http://i182.photobucket.com/albums/x...7/c50b0059.jpg http://i182.photobucket.com/albums/x...7/3e6a6283.jpg http://i182.photobucket.com/albums/x...7/d70c3701.jpg http://i182.photobucket.com/albums/x...7/61808482.jpg http://i182.photobucket.com/albums/x...7/d6f607f5.jpg http://i182.photobucket.com/albums/x...7/c268510d.jpg http://i182.photobucket.com/albums/x...7/003d230f.jpg

boatbob2 05-18-2012 07:18 AM

Nice job........
 
Hi,looking good,im hoping that copper tube from compressor pump,to tank,has a vibration fail safe unit in it (i think thats what its called),or that tube will break quickly.MAYBE a section of Hi-pressure hose??

Steel 05-18-2012 08:34 PM

Actually, I've been trying to run down a supply line of sorts to run permanently. I just fabbed that in there on a temporary basis until I could find one, no luck so far though.

1ownerT 05-19-2012 07:04 PM

Quote:

Originally Posted by boatbob2
Hi,looking good,im hoping that copper tube from compressor pump,to tank,has a vibration fail safe unit in it (i think thats what its called),or that tube will break quickly.MAYBE a section of Hi-pressure hose??

Why would it fail?
When I bought my compressor new it was plumbed in a very similar way with copper tubing.

Coffinswell 05-25-2015 04:00 AM

That a very good restoration Steel, I have a very similar pump to yours, but no identification plate. What size pump is yours and what motor do you drive it with? I am finding it quite difficult to find any information on these pumps this side of the pond. Apologies for hijacking your thread, sent from sunny England.

delawarebill 05-25-2015 07:16 AM

u say 1964 as the yr built ???
 
and does that include the tank too...??????????????????????
if this is correct, u vary well may be sitting next to a bomb.. 50 yrs of use and who knows how often the tank was drained of water... rust, corrosion, reduced wall thickness and BOOM...
my brothers neighbor's compressor blew, luckily he was on the other side of car.. compressor side of car was totaled, along with major wall damage.


All times are GMT -6. The time now is 05:26 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.