1965 impala blinkers wont work - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 04-07-2011, 08:39 PM
Registered User
 
Join Date: Apr 2011
Location: texas
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
1965 impala blinkers wont work

i recently re wired my 1965 impala and now my blinkers dont work. the tail lights them selves work but when i put the blinker on some of the lights dim but dont flash and i cannot figure out what is wrong. i got a harness from painless performance and it all looks to be wired corectly ann of the fuses are good but the lights dont blink if you know of what is wrong it would be greatly appreciated

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 04-08-2011, 02:59 PM
Joe G's Avatar
Registered user
 
Last photo:
Join Date: Nov 2008
Location: St. Paul, MN
Posts: 587
Wiki Edits: 0

Thanks: 78
Thanked 31 Times in 30 Posts
Couple questions:

Is the body grounded?

Did the lights and turn signals work before they got re-wired?

Do the brake lights work?

Has the car been repainted recently? (a common cause of bad grounds)

Are you using LED bulbs?
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 04-08-2011, 03:30 PM
Registered User
 
Join Date: Apr 2011
Location: texas
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Yes the worked before

Yes it is grounded

3 work 1 goes out

No it wasn't painted

No they are regular bulbs
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1965 impala A/C freedom53 General Rodding Tech 3 02-05-2010 03:58 PM
89 mustang blinkers wont work bgardner Electrical 1 01-19-2009 06:13 PM
1965 Cadillac 429 wont strart Kaotickid7 Engine 2 07-02-2008 04:00 PM
Few Questions-1965 Impala EazyDuzIt102 Electrical 2 01-15-2006 08:06 PM
1965 Impala Wont Start EazyDuzIt102 Engine 2 09-04-2005 05:57 PM


All times are GMT -6. The time now is 12:28 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.