1967 Camaro gauge lights - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-19-2010, 06:00 PM
Registered User
 
Join Date: Aug 2010
Location: Oakville, Ontario, Canada
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
1967 Camaro gauge lights

I have replaced the speedometer in my '67 Camaro. While I was there, I replaced all the bulbs for the gauges. After putting everything back together, the gauge lights don't work an the car won't start (electronic ignition). The fuse is ok. I've obviously done something wrong, but not sure what. Any ideas?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-20-2010, 07:03 AM
Registered User
 

Last journal entry: Unpacking
Last photo:
Join Date: Jul 2010
Location: pk, new york
Posts: 91
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
i would check all of your grounds, you may have pulled a wire that you didnt know was attached to something. use a continuity tester also
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 08-20-2010, 08:30 AM
cobalt327's Avatar
WFO
 
Last wiki edit: Intake manifold
Last journal entry: 1980 Malibu Wagon
Last photo:
Join Date: Mar 2009
Location: Atlanta
Age: 59
Posts: 5,037
Wiki Edits: 1616

Thanks: 128
Thanked 595 Times in 545 Posts
Check to see that the connectors coming down the steering column didn't get accidentally disconnected and that the neutral safety switch didn't have a wire knocked off somehow.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1967 camaro suspension codeman18 Suspension - Brakes - Steering 3 03-31-2008 10:49 AM
Guages are dead gtipton Electrical 4 05-09-2007 09:14 PM
1967 Camaro Doug Graham Introduce Yourself 1 04-11-2007 07:00 AM
1967 firebird - camaro conversion Johnny Bravo Body - Exterior 3 10-10-2003 12:30 PM
Custom tail lights for a 69 camaro????? chevyelc81 Body - Exterior 1 02-24-2003 07:59 PM


All times are GMT -6. The time now is 07:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.