1969 Camaro - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > General Discussion> Hotrodders' Lounge> Introduce Yourself
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 10-02-2007, 04:36 AM
Registered User
 
Join Date: Oct 2007
Location: Maryland
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
1969 Camaro

My son and I are trying to keep a 1969 Camaro On The road
We put a 350 In it last year, and reused the year old intake and 550 Holly carb that was on the 307 we took out. When we went to set it up we found the carb to have a lot of pitting and medal flacking off the inside of carb. I bought a new 650 Holly and all was good until this week. The car started running bad again. I got my guy that helps me open up the carb and the same this is happening to the inside.
We have a new fuel filter in-line. My question is What could be in the gas to eat up a carb in a year.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 10-02-2007, 05:27 AM
Henry Highrise's Avatar
Lost in the 60's
 
Last wiki edit: Removing stuck fasteners Last photo:
Join Date: Dec 2001
Location: Dixieland
Age: 69
Posts: 15,189
Wiki Edits: 4

Thanks: 0
Thanked 11 Times in 10 Posts
Welcome to Hotrodders......Best to ask your question over in the Engine forum. It may not be the gas...sounds like you have a electrolisis going on to me.
Reply With Quote Quick reply to this message

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1969 Camaro, CDRITTER Introduce Yourself 1 12-02-2005 11:04 AM
X33 or X77 1969 Camaro Identification JimKramer Hotrodders' Lounge 0 09-02-2005 10:33 AM
1969 Camaro Tach Installation Help daveh Electrical 2 02-09-2005 11:54 AM
1969 Camaro Tach daveh Electrical 2 01-27-2004 06:49 PM
1969 Camaro dash lights out follow-up daveh Electrical 8 06-18-2003 06:25 AM


All times are GMT -6. The time now is 03:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.