1969 chevy C20 pickup alternator problem - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 12-08-2012, 12:05 AM
Registered User
 
Join Date: Jun 2012
Posts: 12
Wiki Edits: 0

Thanks: 4
Thanked 0 Times in 0 Posts
1969 chevy C20 pickup alternator problem

Hello, my 69 pickup had the old school external regulator on the old alternator and the regulator went bad and was charging at 15-16 volts. So i bought a one wire alternator and it is only charging at 12 volts which means its not working right? does the truck need to be re-wired to be able to work on a one wire internally regulated truck? Also, can i still get the old school external regulators? At autozone or advanced auto parts? cuz if the truck has to be re wired Id rather just try to get a new voltage regulator at autozone or advanced if possible.

Thanks
Chase

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 12-08-2012, 06:28 AM
EOD Guy's Avatar
Registered User
 
Last photo:
Join Date: Aug 2010
Location: Alabama
Posts: 2,150
Wiki Edits: 0

Thanks: 1
Thanked 156 Times in 144 Posts
Well sort of..... buts it's very easy, a couple of jumpers and one new wire.
Attached Thumbnails
Click image for larger version

Name:	12sialt.jpg
Views:	646
Size:	19.3 KB
ID:	69637  
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 12-08-2012, 10:41 AM
spacytracy's Avatar
Registered User
 

Last journal entry: New neon sign for the garage
Last photo:
Join Date: Nov 2010
Location: utah
Posts: 96
Wiki Edits: 0

Thanks: 0
Thanked 15 Times in 13 Posts
I went through 4 alternators for my 1970 chevrolet 1/2 ton truck before I got one that actually worked. I bought from O'Reillys aka china parts depot.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Painting 1969 Chevy C20 Chase43 Body - Exterior 1 11-11-2012 10:01 PM
New Member 75 Chevy C20 clicketyclack Introduce Yourself 2 07-04-2010 09:01 PM
76 Chevy C20 69ChevyC10 Transmission - Rearend 5 12-21-2008 09:06 AM
1969 chevy c10 pickup Ray Thompson Introduce Yourself 1 05-30-2006 06:14 PM
87 Chevy Pickup Timing Problem gs70ss Electrical 2 10-19-2003 12:04 PM


All times are GMT -6. The time now is 12:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.