Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Transmission - Rearend (http://www.hotrodders.com/forum/transmission-rearend/)
-   -   1970 Camaro SS with KM Speedo (http://www.hotrodders.com/forum/1970-camaro-ss-km-speedo-61707.html)

Houman SS '70 04-22-2005 03:53 PM

1970 Camaro SS with KM Speedo
 
Dear Friends,

I've got this 1970 Camaro SS which is equipped with it's original Speedometer, and since my car was ordered by Chevrolet Division in Europe it is marked in Km's and not MPH.

Now, my Speedo reads app. 20 Km's higher.
I also have a spare Speedometer which I took out of a 1978 Camaro with MPH's. As I looked more close, I found out that the 1978 Speedo when not running is got it's arrow pointing below the 0 MPH, but mine is set at 0 Exactly.

Do you think that this is why my car is showing 20km's more?
Should I draw the Speedo Arrow about 20 km's backward?
I mean should be pointing below the 0 mark when not running? Or I'm facing another problem?

Thanks for your comments.

Houman SS '70

dollybud 04-23-2005 07:15 AM

Where you are do they use the metric system? Cranking back below the "o" is no answer. If you want to stay with the KM's change the speedometer cable gear to compensate for the 20 km its out. MPH to KM and KM to MPH is simple math. Check the Knowledge Base for info on the gears. ;)


All times are GMT -6. The time now is 04:36 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.