1970 chevelle wont crank, 454 engine - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 04-19-2008, 08:43 AM
jum jum is offline
Member
 
Join Date: Jul 2003
Location: Richmond Va.
Age: 59
Posts: 77
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
1970 chevelle wont crank, 454 engine

A week ago diaphram busted in fuel pump filling engine with gas. Drained all of it out and changed oil twice, starting for a couple seconds in between oil change. Running fine this morning but tapping from under valve covers. Found three valves loose and tightened them up. Now motor wont even attempt to crank. New battery so its got plenty of juice. What could be my problem? Thanks in advance, Jim

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 04-19-2008, 09:31 AM
Jmark's Avatar
Registered User
 
Last photo:
Join Date: Sep 2003
Location: phoenix
Age: 61
Posts: 4,808
Wiki Edits: 0

Thanks: 0
Thanked 3 Times in 3 Posts
What does it do, if anything? Does the starter click? Do the lights work? Does the starter engage but not crank the engine? Can you turn the engine over manually? Did you knock a wire loose somewhere?

Would not be the first time i've seen a "new" battery that was no good.

Need to start with the basics to get an idea where it went wrong.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 04-19-2008, 09:35 AM
jum jum is offline
Member
 
Join Date: Jul 2003
Location: Richmond Va.
Age: 59
Posts: 77
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Found out some of the problem. Pulled spark plugs and back 4 cylinders full of gas. Now it will turn over. Bad carb? Thanks, Jim
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 04-19-2008, 10:55 AM
68NovaSS's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Working with chromed bolts
Last journal entry: New to me T-Bucket
Last photo:
Join Date: Sep 2002
Location: Nine Mile Falls, Washington
Posts: 5,223
Wiki Edits: 9

Thanks: 102
Thanked 131 Times in 122 Posts
Sounds like you were hydro locked. Are the floats stuck now? Do you have fuel running down the carb when cranking? After cranking, pull the plugs to see if they're wet.
__________________
Boost adds dignity to what would otherwise be a vulgar brawl...

Midnight Sun Street Rod Association
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 04-19-2008, 11:39 AM
RPM's Avatar
RPM RPM is offline
World Class ASE tech
 
Last photo:
Join Date: Nov 2004
Location: Hills of TN
Age: 64
Posts: 704
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Be sure you change the oil again!!!!
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help ! - Chevelle / Olds 442 Clutch Linkage MARSHMAN 442 General Rodding Tech 1 09-10-2007 08:53 PM
67 chevelle 12 bolt fit in 70 chevelle? 70chevelle327 Transmission - Rearend 11 09-11-2006 07:52 AM
forged crank question Ratoflic Engine 2 04-18-2006 04:50 AM
Help With What To Do With A 66 Chevelle I bought - Trades? daveh Hotrodders' Lounge 17 03-29-2006 04:26 PM
1970 Chevelle Interior bigborda Interior 9 07-17-2005 07:48 PM


All times are GMT -6. The time now is 11:14 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.