1970chevy c10 charging system probs - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 12-21-2008, 10:22 AM
Registered User
 
Join Date: Dec 2008
Location: sacramento
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
1970chevy c10 charging system probs

I have a 1970 chevy c10 w/350 ci block. I bought it a few years back and although i love the truck it has constant dead battery issues and cant even power a radio sufficently.

The previous owner left several wire messes under the hood and i cant make whats what anymore. My question is this: is the battery supposed to have a cable going direclty to the regulater/charging sytem?? Right now the only cable going back to the positive on the battery is the starter cable. The fuse box also is sending 2 wires to the starter,one purple and one blue.

Does this sound correct?

Has anyone had wiring issues with older vehicles like mine?

Should the regulator be sending a wire directly to battery to keep its charge? Or does the charging process happen through the wires going to the starter, and back up to batt?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 12-21-2008, 07:24 PM
Registered User
 
Join Date: Aug 2006
Location: Alexandria, VA
Posts: 1,764
Wiki Edits: 0

Thanks: 4
Thanked 66 Times in 64 Posts
It sounds like the wiring might have been converted to an alternator with a built-in regulator, since you don't mention the horn relay being part of the circuit.

With a built-in regulator (like the GM 10si alternator), the battery cable runs directly to the starter lug. One or two smaller power feed wires are connected to the lug, and they will run back up to a junction on the firewall. From that junction the alternator charge wire runs over to the BAT terminal on the alternator.

The main power feed is usually a red/orange 10 gauge wire, but maybe yours has been replaced with a blue wire.
The purple wire is used to activate the starter, so it comes from the ignition switch.

You could run a charge wire directly from the battery terminal over to the alternator, using a 10 gauge wire with a 14 gauge fusible link on the battery end. Many newer GM rucks use this type of connection.

Bruce
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 01-24-2009, 11:41 PM
Registered User
 
Join Date: Jan 2009
Location: alabama
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
re: 70 chevy c10 charging system probs

I too have a 1970 c10...when i got it i had a few charging problem. turned out to be bad/dirty connection on the alt its self so i would definately check that...as for the wiring problem...i have one single red wire that runs from the positive batt post to a little ecm box on the drivers side of the truck....from there all the wires from the alt tie in together... hope i help in some way!! good luck
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turbo vs Supercharger - Write up!! FastChevyTruck Engine 107 02-16-2011 01:18 PM
Ignition system info................ poncho62 Electrical 18 10-11-2008 11:10 PM
Charging system info............... poncho62 Electrical 11 11-26-2005 09:53 PM
Should I keep my hydro-boost brake system? drlindz Suspension - Brakes - Steering 3 09-11-2003 10:38 PM
charging system troubles- help! dmorris1200 Electrical 13 07-30-2003 08:47 PM


All times are GMT -6. The time now is 10:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.