1971 Chevy Nova steering - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Suspension - Brakes - Steering
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 06-19-2003, 05:26 PM
ToYoungToCare's Avatar
Member
 
Join Date: Jun 2003
Location: Neoga
Age: 27
Posts: 43
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
1971 Chevy Nova steering

I recently purchased a 1971 chevy nova 4dr all original with 23000 miles on it. Tho its in pretty great condition for its age, it squeaks when i cut the wheal all the way in a certain direction. Everyone i've asked says theres nothing i can do about it. If anybody can tell me diff i would great appreciate it

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 06-20-2003, 05:46 AM
3rdmember
 
Last photo:
Join Date: Nov 2002
Location: Berthoud,CO
Age: 59
Posts: 348
Wiki Edits: 0

Thanks: 0
Thanked 1 Time in 1 Post
have ya tried..

greasing the front suspension and maybe tightening the subframe to body bolts?
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 06-22-2003, 12:05 AM
Member
 
Last photo:
Join Date: May 2003
Location: Shreveport LA
Age: 64
Posts: 5,103
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Is it a power steering belt squealing? If so, it's normal if you cut the wheel all the way left or right.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 06-24-2003, 08:24 PM
73 Nova Guy's Avatar
FROM MY COLD DEAD HANDS!
 

Last journal entry: Swinger
Last photo:
Join Date: Feb 2003
Location: Cameron Park California
Age: 30
Posts: 86
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Had the smae prob on my 73. Add a bit of fluid. It usually squeaks when the pump strains the belts 'cause it doesn't have enuf fluid. Also when i do this i tighten the belt because whether it looks like it needs it or not, it does.-Justin
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 06-24-2003, 08:49 PM
ToYoungToCare's Avatar
Member
 
Join Date: Jun 2003
Location: Neoga
Age: 27
Posts: 43
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
alright man thanxs for the reply, i'll try all the suggestions as soon as the car gets back from the shop.
Reply With Quote Quick reply to this message

Recent Suspension - Brakes - Steering posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 05:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.