Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Hotrodding Basics (http://www.hotrodders.com/forum/hotrodding-basics/)
-   -   1972chevy no action (http://www.hotrodders.com/forum/1972chevy-no-action-229443.html)

Wildboomer 02-11-2013 02:28 PM

1972chevy no action
 
Have a 1972 Chevy c10. Turn key and nothing happens. Has new battery. Pull lights on and nothing happens. Cables from battery are good. Turn key and no panel lights or gauges register either. Any ideas?

T-bucket23 02-11-2013 03:16 PM

If you jump the starter (large post to s terminal) does it crank. If so you may have a blown or disconnected fusible link. On the large stud on the starter there is generally the battery wire and up to 3 others. These others feed everything else generally.

If you jump the starter and it doesn't crank either one or both of your battery cables has a bad connection.

S10 Racer 02-11-2013 03:20 PM

1 Attachment(s)
Look for a fusible link in the system near the battery, something that looks like the picture. It is probably blown and needs replaced.

snakebit68 02-11-2013 03:56 PM

Battery
 
Yep, sounds like a fuseable link. True, try jumping accrossed starter solenoid posts and see what happens. May also be a bad block ground.

Falcon Wagon 02-11-2013 05:48 PM

As my Dad would always say make sure not to use a good screwdriver


All times are GMT -6. The time now is 10:05 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.