1973 K-10 - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum

Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Hotrodding Basics
User Name
lost password?   |   register now

LinkBack Thread Tools
  #1 (permalink)  
Old 07-19-2010, 02:55 PM
Registered User
Join Date: Jul 2010
Location: Orange Park
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
1973 K-10

i have a 73 k-10 rebuilt, bored 30 over sports cam. all eldbrock.every thing is.It has MSD and has 11.1.1 compression. and i keep blowing reg starters. some say buy a strt to turn it but some say its my timing. wht do i need to do any answers help me out.904-213-9869. my name is Brandon

Reply With Quote Quick reply to this message
Sponsored Links
  #2 (permalink)  
Old 07-19-2010, 07:34 PM
techinspector1's Avatar
Senior Curmudgeon
Last wiki edit: DynoSim combinations Last photo:
Join Date: Oct 2005
Location: Hemet, California, USA
Age: 73
Posts: 14,052
Wiki Edits: 326

Thanks: 1,049
Thanked 1,431 Times in 1,153 Posts
Interrupt the hot line to the MSD with a line that goes back to the dash or other convenient place that you can reach easily. Install a momentary on/off switch that breaks the juice to the MSD when pushed. Push the button, get the motor turning over with the starter and release the button.
Reply With Quote Quick reply to this message

Recent Hotrodding Basics posts with photos
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
7 deg versus 10 degree ? Guy Hiltz Engine 3 10-29-2006 01:05 AM
Brake lights switch oldsmo Electrical 4 10-19-2006 12:23 PM
unusual 10 bolt GM diffy off '75 SW... paulo 1 Transmission - Rearend 2 08-16-2006 09:10 PM
Engine Vacuum is showing 10 and no higher? ataririder Engine 42 02-18-2003 08:12 PM
10 0/0 theory dinger Hotrodders' Lounge 3 09-12-2002 09:14 AM

All times are GMT -6. The time now is 06:35 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.