1976 Cougar XR7 - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 05-08-2003, 06:14 PM
New Member
 
Join Date: Apr 2003
Posts: 10
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post 1976 Cougar XR7

I recently aquired a '76 Cougar XR7. It has a Ford 400 with a 2 barrel and a miss. I know nothing about Fords (didn't even know Ford made a 400) and am curious for any imput on this car. Is the 400 a dependable motor? Any inherent problems? What to look out for with this car? Any thoughts on the miss? Any help is appricated!

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 05-08-2003, 06:33 PM
crazy larry's Avatar
Member
 

Last journal entry: better comparison before and after shots
Last photo:
Join Date: Oct 2002
Location: East Texas
Age: 43
Posts: 2,298
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

the 400 is a pretty good motor, had one in a 78 f150. damn near killed me. only problem I ever had was trying to find aftermarket stuff. see (correct me if i'm wrong) the 400 is a offspring of the cleveland family of engines. has good heads as is, just never got off the ground as a performance engine. (gas crisis and emissions and for some reason ford got out of the performance market in the early 70's) i do believe that a lot of cleveland stuff interchanges with the 400 and to an extent with the 351M400. I'll double check when I get home, and maybe I should have delayed posting in order to keep my foot out of my mouth, but I aint doing nothing but killing time right now.......as far as the miss goes, see what ignition it has, i'm sure its a duraspark, never knew what to do with them. (my 78 would cut out on hard acceleration when it was warm. never did it when it was cool) there are some guys here that will know what to do. can you describe the circumstances around the miss a little more detailed????
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 05-09-2003, 01:54 AM
dmorris1200's Avatar
doesn't play well with others
 
Last photo:
Join Date: Feb 2002
Location: Maine
Age: 49
Posts: 1,834
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

Here is a link with a little info on the 400 engine. Mentions casting problems with the pre-1977 castings.

Cleveland Family


__________________
BUILT FORD TOUGH
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 11:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.