Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - 1977 Chevy K20: Engine Suffers from Hesitation/Power Loss When In Drive
View Single Post
  #15 (permalink)  
Old 02-07-2012, 02:00 PM
lt1silverhawk's Avatar
lt1silverhawk lt1silverhawk is offline
"But how do it know?"
 
Last wiki edit: How to rebuild a Rochester Quadrajet 4MV carbureto... Last photo:
Join Date: Mar 2010
Location: Lakewood, CA
Posts: 2,287
Wiki Edits: 132

Thanks: 101
Thanked 24 Times in 17 Posts
This morning, I started the truck to move it up the drive way for the street sweeper. It started up fine and reversed up the drive way with no issues.


After the sweeper passed, I drove it back down the drive way under its own power, without giving it any gas. Once onto the street, I gave it some gas and it started stumbling again. I put it in Park and revved the engine. I hesitated slightly around 3,000 rpm. I then slowly drove it in Forward and Reverse along the side walk several times. It would stumble in Forward, but no issues in Reverse.


I put it back in Park, revved the engine close to 4,000 rpm, and it did so with no issues. It began idling at around 1,000 rpm, vs 750 rpm initially. I then drove the truck up and down the street and it drove and shifted like normal: a little hard in 1-2, and then somewhat hard in 2-3.


I am still at a loss as to what is going on. It almost sounds as if revving the engine cleared up something fuel related. Any ideas?



EDIT: Gonna check the clear fuel filters first chance I get to see if the fuel is crap (again). Hopefully no later than tomorrow.
Reply With Quote