1980 corvette alarm - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-05-2006, 08:05 PM
Registered User
 
Join Date: Aug 2006
Location: Kansas
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
1980 corvette alarm

My corvette alarm started going off yesterday all by itself. It is a factory installed unit and came on the car originally. I have tried several ways to get it to rearm but it just keeps sounding off. I can only silence it by disconnecting the battery. Any ideas ?

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-06-2006, 12:12 AM
docvette's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Rebuild an alternator Last photo:
Join Date: Mar 2004
Location: Lafayette, california
Age: 62
Posts: 7,362
Wiki Edits: 12

Thanks: 0
Thanked 6 Times in 3 Posts
Doc here,

For now..pull the fuses, and disconnect the siren..that'll keep it quiet.

On mine, the module was in the left rear quarter panel hidden vault well..Check there for a removable door..(they have a few spots I can't remember where they all are..) If it's there , check the plug and harness for bad, burned, bent or corroded pins..and / or a damaged module (road fodder..) If good..

ON mine, all the wires junction at the left side center console panel and went under the cluster / dash from there..a good spot to check..and troubleshoot from..your going to need a factory alarm manual for your system also. If you get one...please post it..I need one!

BTW..mine was abandoned long ago..about 2 or 3 aftermarket systems ago..But all the "EXTRA " wire was left..so this time I stripped it all out in favor of the new system, what so far has worked flawlessly for over 4 years...

Doc
__________________
Aftermarket Solutions
Electronic & Electrical
Innovations
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing a Corvette IRS in a 34 Coupe Mc D's 34 Coupe Suspension - Brakes - Steering 12 05-18-2010 12:20 PM
alarm system crownver Electrical 5 05-26-2006 04:21 PM
1980 corvette battery keeps going dead? Aboveknee Electrical 5 01-23-2004 03:56 PM
1980 Rochester Corvette ratt7 Engine 2 10-31-2002 12:20 PM


All times are GMT -6. The time now is 12:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.