1984 Corvette 700 Trans Wont Shift Up - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 06-06-2006, 11:30 AM
Registered User
 
Join Date: Jun 2006
Location: chiefland fl
Posts: 5
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
1984 Corvette 700 Trans Wont Shift Up

Hey guys, first post, I just got a 1984 Corvette with the 700 trans, but it will not shift up, 1st & reverse are strong, and if i drive a short distance and down shift, it will brake down to first, I adjusted the tv, it is fine & free.
I was thinking of flushing the lines going into the radiator, (because the car has sat for awhile), how can i flush it at home with no special tools to speak of? got a new filter and b&m shift kit for it, but am hesitant to put it in since i may have to drop the tranny, any info would help thanx.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 06-06-2006, 01:19 PM
hotrodf1's Avatar
Chasing dreams with a ball bat
 
Last photo:
Join Date: Dec 2003
Location: Evansville, IN
Age: 37
Posts: 545
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I think I would pull the governor out and check to make sure that it is free as well. Would be on the driver side , a little tophat looking deal with a spring like would be on a master cylinder. Pull the cap off, and slide the governor out and see if the weights move freely. Probably will be okay, but you never know.

As far as flushing the system with the engine running, I suppose you could unhook both lines, have one empty container, and one with fresh fluid and just see if it would draw in the fresh and spit out the old. I guess it would take a bunch of fluid to do it that way.

The TV cable is pulled tight at WOT, right?
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 06-06-2006, 01:37 PM
Registered User
 
Join Date: Jun 2006
Location: chiefland fl
Posts: 5
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Yeah, TV is good, I was thinking of the Governer, I gotta drop the exhaust for that.. good idea on the radiator, maybe i should check the GOV before I install the B&M kit & filter, guess in the back of my head was hoping the shift kit and filter would help the prob
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 06-06-2006, 08:23 PM
airworld2's Avatar
Member
 
Last photo:
Join Date: Mar 2003
Location: houston texas
Posts: 583
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
vett

try this with car on a lift, or wheels off the ground rotate drive shaft listen to governor cap, this will tell you if gear is broken or apple cored. if it clicking the governor is moving. next drop the pan and look inside for dirt or metal most the time its a stuck t/v valve in the valve body. if your governor is for some reason stuck or sticking you have big trouble, 700 only hang governor from metal (bad gear train planets ring gear)
__________________
airworld2
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
fastest muscle pre 1970 81elcamino Hotrodders' Lounge 86 01-19-2009 05:53 PM
Trans seems to shift into neutral during the 3-4 (overdrive) shift Rocketmann66 Transmission - Rearend 2 06-12-2005 11:21 AM
700r4 won't shift at WOT Alex99 Transmission - Rearend 39 02-15-2005 10:08 PM
1984 Corvette bolt ons. KeithB123 Engine 10 11-19-2003 10:26 AM
Corvette Trans T-400 or 200r4, johnnybegood Transmission - Rearend 9 10-22-2002 07:29 PM


All times are GMT -6. The time now is 12:01 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.