1985 S10 Blazer 2.8 Oil Problems - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 02-21-2005, 06:00 PM
ChevelleSS_LS6's Avatar
Jeep XJ and a Javelin
 
Last wiki edit: Compression test
Last journal entry: August 9, part III
Last photo:
Join Date: Dec 2001
Location: Grand Rapids, Michigan
Age: 28
Posts: 1,610
Wiki Edits: 7

Thanks: 3
Thanked 0 Times in 0 Posts
1985 S10 Blazer 2.8 Oil Problems

Hey all,
A girl at my school (I don't like her more than as friends, so no teasing, ok?) has a vehicle as described on the thread title; a 85 S10 (small) blazer with a carb'd 2.8 v6.

Well, last week her oil pressure started going up and down a lot, and so she got her oil changed. It's still that way, and she needed to add a quart of oil today. I was speaking with her about it, and she told me the other day the fuel tank was covered in oil.

The both of us wonder what is up with the oiling system on that vehicle; I peeked under the hood, and it's pretty clean, a little dusty from what I have seen. No oil film/mist all over everything like I expected it to be.
Thanks,
matt
p.s. she seems to know a lot about cars, but she's 7 years older than me, and weighs probably 1 1/2 times as much, so don't tell me to take her on a date.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 02-21-2005, 06:27 PM
Mighty Mouse S-10's Avatar
Cleverly disguised as grownup
 

Last journal entry: Hollman & Moody
Last photo:
Join Date: Dec 2004
Location: Huntersville, N.C.
Age: 55
Posts: 140
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I had a very similar problem on a V-8. found the oil pressure sending unit was leaking. Installed a new sending unit, wiped the oil off the bottom of the truck, and all symptoms disappeared. Good luck. MM
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 02-22-2005, 02:37 PM
Member
 
Join Date: Mar 2004
Location: Oklahoma City
Age: 36
Posts: 72
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
I agree, I had a 2.8L with the same symptom, and the sender had gone bad and was leaking externally as well...
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine swap for Blazer S10 ducktruck87 Engine 31 07-01-2010 08:44 PM
tpi s10 having some problems blwn98gtp3800 Engine 15 09-05-2008 07:43 AM
1989 s10 blazer 4x4 4.3L 81elcamino Engine 5 12-22-2003 12:15 PM
96 chevy s10 blazer turboed quick jesshwarren Engine 2 11-28-2003 03:15 PM
Blazer S10 4.3 idles poorly bigjack Engine 1 03-30-2003 08:38 AM


All times are GMT -6. The time now is 07:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.