1986 Olds No Power - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum

Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
lost password?   |   register now

LinkBack Thread Tools
  #1 (permalink)  
Old 11-03-2008, 03:58 PM
Registered User
Join Date: Sep 2008
Location: south philly
Age: 44
Posts: 6
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
1986 Olds No Power

I Have A 1986 Olds Cutlass 3.8l When I Start It The Choke/oil Light Comes On. When The Car Is Running It Sounds Good But When I Try To Drive It,it Has No Power. Any Suggestions?

Reply With Quote Quick reply to this message
Sponsored Links
  #2 (permalink)  
Old 11-03-2008, 06:30 PM
DoubleVision's Avatar
Not Considered a Senior Member
Last photo:
Join Date: Oct 2002
Location: Heart Of Dixie
Age: 41
Posts: 10,675
Wiki Edits: 0

Thanks: 15
Thanked 65 Times in 60 Posts
I hated those oil/choke lights, confusing they were. Anyways, With the air cleaner removed and the engine running at operating tempature, move the throttle, make sure the choke plate isn`t shutting or partially shutting when you do so. you may find the choke isn`t operating at all and is only partially open. This, in a sense is choking the engine to death, it`s giving it additional fuel but little air and it`s got to have air to make power.
Reply With Quote Quick reply to this message

Recent Engine posts with photos
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Please select your insurance company (Optional)


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
No Power 4 BOLTS Electrical 4 01-17-2006 12:27 AM
Olds 98 Ignition Module Problems awbazar Electrical 1 01-12-2004 07:42 AM
Car Audio Question Thuggishruggish3000 Interior 14 12-23-2003 09:48 AM
Wanted: 1959-1964 GM (caddy, buick, olds, etc) POWER VENT WINDOW MOTORS KUSTOMRYDER Hotrodders' Lounge 0 03-15-2002 07:23 PM
Wanted: 1959-1964 GM (caddy, buick, olds, etc) POWER VENT WINDOW MOTORS KUSTOMRYDER Interior 0 03-15-2002 07:22 PM

All times are GMT -6. The time now is 12:19 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.