1987 Chevy Tbi Problems - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 02-10-2007, 08:58 AM
Member
 
Join Date: Nov 2004
Location: The Show me State
Age: 38
Posts: 47
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
1987 Chevy Tbi Problems

I have a 1987 Chevy 3/4 ton 4x4 that has been giving me some problems lately. AFter it warms up it starts to backfire (not loud backfire more like small pops) out the exhaust when idleing, It doesnt doesnt backfire when running down the road mainly just at idle. I put it on a computer account the check engine light was coming on after it warmed up also. Error code 44 lean, Running 44 lean in open loop, During limp mode there is no backfireing. Also during the warmup, right before the check engine light comes on you can feel a small surge of power like someone shot some ether into the throttle body then bang the check engine light comes on. Thanks for any help.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 02-10-2007, 09:23 AM
nitro_baller4692's Avatar
floppers forever
 
Join Date: Jun 2006
Location: illinois
Posts: 791
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
idle air control valve could be sticking,take it out and clean the carbon off don't scrape the plunger thats the seat of the valve and don't like scratches.
also you've checked to make sure that the temp. sensor is reading correctly,if reading higher temps then should be it will cause the computer to read that it needs less fuel,causing a lean condition.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 02-10-2007, 11:14 AM
bondo's Avatar
Member
 
Last photo:
Join Date: Nov 2002
Location: Chaumont Bay N.Y.
Posts: 960
Wiki Edits: 0

Thanks: 7
Thanked 15 Times in 15 Posts
How about the Fuel Filter,..??..??.... When was the last time it was Changed,..??...

Maybe it Can't get it's Fuel,...... That'll cause a Lean Condition........
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 02-10-2007, 11:43 AM
1931 steve's Avatar
Hotrodders.com Moderator
 
Last wiki edit: How to rebuild an engine Last photo:
Join Date: Nov 2004
Location: Michigan
Age: 42
Posts: 1,207
Wiki Edits: 4

Thanks: 0
Thanked 0 Times in 0 Posts
I have seen many with the same symptoms that you are having, and they have had bad fuel pumps. These engines will still run OK most of the time with lower than specification fuel pressure but at times it will lack power and have a lean condition pop at idle.

Check your fuel pressure and even if you are 1lbs low replace the fuel pump and fuel filter.

Code 44 will set with a bad fuel pump.

Hope this helps

Steve
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 02-10-2007, 04:49 PM
Registered User
 
Join Date: Feb 2007
Location: Scottsdale Az
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
fuel filter

All the replys are accurate....I have always started with the fuel filter because it is the least expensive. Code 44 sets with a bad fuel filter
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 02-10-2007, 05:08 PM
71C10's Avatar
U.S. Army Retired
 
Last photo:
Join Date: Sep 2005
Location: Texas
Posts: 266
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
While your trouble shooting, check for vacuum leaks, TBI base gasket, vacuum hoses and intake gaskets. Check ground wires and TBI wires as well.
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 02-10-2007, 05:15 PM
Member
 
Join Date: Nov 2004
Location: The Show me State
Age: 38
Posts: 47
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Thanks for all the help fellas.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Chevy TBI manifold with carb? Augusto Engine 13 02-10-2007 10:16 AM
90' Chevy TBI kohle1ce Engine 2 10-18-2006 09:55 PM
chevy tbi experts??? k-star Engine 29 11-24-2004 06:52 AM
1986 305 chevy vs. 1987 305 chevy new style small block mtinsley Engine 2 08-22-2003 11:55 AM
89 Chevy P.U. TBI ????? catdad2u Engine 1 11-12-2002 02:52 PM


All times are GMT -6. The time now is 07:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.