1989 Beretta GT - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 09-29-2002, 03:17 PM
Registered User
 
Join Date: Sep 2002
Location: Maine
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Question 1989 Beretta GT

I have a 2.8 automatic that starts to buck and stalls out after fifteen to thirty minutes running and will not start for an hour or more. Does anyone have any ideas to what this is.

Once it stalls I can sometimes get it started, but when put in gear it will stall out. I've tacked the car up to three grand and dumped it into gear to get it to move so that I could make it home, but when it goes down around a grand rpm it will start to buck.

Thanks

[ September 29, 2002: Message edited by: jacropley ]</p>

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 09-29-2002, 03:34 PM
roys63's Avatar
Member
 
Last photo:
Join Date: Dec 2001
Location: Nc
Age: 63
Posts: 907
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

May be the intank fuel pump ? can you hear the pump running when trying to start after it shuts down? or is the battery dead? And you have to jump start to get running again if so you need a alt.

[ September 29, 2002: Message edited by: roys63 ]

[ September 29, 2002: Message edited by: roys63 ]</p>
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 09-29-2002, 03:53 PM
Big Mac's Avatar
Registered User
 
Join Date: Sep 2002
Location: Ontario, Canada
Posts: 9
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Lightbulb

After it stalls, will it still crank over but just not start or will it not even turn over?

Usually if an engine quits after warming up and then runs again when it is cooled down it will be a bad coil. On that car you have three coils mounted to a module, and each coil runs two cyls. If you check your spark plug wires for a weak spark at the spark plug you will be able to narrow down which coil is bad. Make sure you check this when the car is hot and won't start. And you might not find a plug that doesn't spark it might just be a weak yellow spark. (spark should be blue)
__________________
Real Rods are Built Not Bought!
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 09-29-2002, 03:54 PM
Big Mac's Avatar
Registered User
 
Join Date: Sep 2002
Location: Ontario, Canada
Posts: 9
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Lightbulb

After it stalls, will it still crank over but just not start or will it not even turn over?

Usually if an engine quits after warming up and then runs again when it is cooled down it will be a bad coil. On that car you have three coils mounted to a module, and each coil runs two cyls. If you check your spark plug wires for a weak spark at the spark plug you will be able to narrow down which coil is bad. Make sure you check this when the car is hot and won't start. And you might not find a plug that doesn't spark it might just be a weak yellow spark. (spark should be blue)
__________________
Real Rods are Built Not Bought!
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 01:32 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.