1990 Chevy k1500 problem - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 07-15-2012, 12:16 PM
Registered User
 
Join Date: Jul 2012
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
1990 Chevy k1500 problem

Hello,

I have a 1990 Chevy k1500 that i just replace the engine in it with a high performance 350 engine. The engine will start and idle but it wont rev up when you step on the pedal and when I tried to shift it out of park to reverse nothing happen. It will shift into drive though so I'm not really sure what is going on. Can anyone help me?

Thank you

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 07-15-2012, 12:52 PM
Crosley's Avatar
Hotrodders.com Moderator
 
Last wiki edit: T-350 rebuild tech
Last journal entry: Bar under the dash
Last photo:
Join Date: Nov 2002
Location: ... USA
Posts: 8,073
Wiki Edits: 1659

Thanks: 324
Thanked 97 Times in 94 Posts
Quote:
Originally Posted by dusjudd View Post
Hello,

I have a 1990 Chevy k1500 that i just replace the engine in it with a high performance 350 engine. The engine will start and idle but it wont rev up when you step on the pedal and when I tried to shift it out of park to reverse nothing happen. It will shift into drive though so I'm not really sure what is going on. Can anyone help me?

Thank you
You indicate the engine will not rev up

Does the vehicle act like the trans is in gear when you have the shifter in park? Or is there an engine problem?

Is the shifter a stock GM unit? Any trans work done during engine swap?

What transmission is used?

__________________
Some people are like Slinkies... Not really good for anything, but they still bring a smile to your face when you push them down a flight of stairs.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 07-15-2012, 02:24 PM
Registered User
 
Join Date: Jul 2012
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Yea it will not rev. I had someone push on the pedal and the throttle body will open but it doesn't rev. It doesn't act like it is in gear when its in park. It is the factory shifter and trans. We didn't do anything to the trans when we replaced the engine. The engine seems to be working just fine.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 07-15-2012, 09:26 PM
Crosley's Avatar
Hotrodders.com Moderator
 
Last wiki edit: T-350 rebuild tech
Last journal entry: Bar under the dash
Last photo:
Join Date: Nov 2002
Location: ... USA
Posts: 8,073
Wiki Edits: 1659

Thanks: 324
Thanked 97 Times in 94 Posts
Quote:
Originally Posted by dusjudd View Post
Yea it will not rev. I had someone push on the pedal and the throttle body will open but it doesn't rev. It doesn't act like it is in gear when its in park. It is the factory shifter and trans. We didn't do anything to the trans when we replaced the engine. The engine seems to be working just fine.

Sounds like an engine problem if it will not rev up when in park and you say the vehicle does not act like it is in gear
__________________
Some people are like Slinkies... Not really good for anything, but they still bring a smile to your face when you push them down a flight of stairs.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 07-16-2012, 10:48 PM
Registered User
 
Join Date: Jul 2012
Posts: 3
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
well we got the engine to rev up and going into gear. The new problem it that it is running really hot. The timing is set at TDC. Is this the right timing for a 350?
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 07-17-2012, 06:06 AM
Crosley's Avatar
Hotrodders.com Moderator
 
Last wiki edit: T-350 rebuild tech
Last journal entry: Bar under the dash
Last photo:
Join Date: Nov 2002
Location: ... USA
Posts: 8,073
Wiki Edits: 1659

Thanks: 324
Thanked 97 Times in 94 Posts
Quote:
Originally Posted by dusjudd View Post
well we got the engine to rev up and going into gear. The new problem it that it is running really hot. The timing is set at TDC. Is this the right timing for a 350?
You need to ask engine questions in the engine forum for responses
__________________
Some people are like Slinkies... Not really good for anything, but they still bring a smile to your face when you push them down a flight of stairs.
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1990 chevy k1500 5 speed conversion? 1990k1500 Transmission - Rearend 2 01-02-2012 05:22 PM
1990 chevy k1500 tranny stopd going into overdrive? gofastz Transmission - Rearend 2 09-06-2011 07:36 AM
1990 K1500 TBI with 1982 chevy 350 no power ljgriggs Engine 10 04-27-2011 02:02 PM
1990 chevy k1500 pickup left front axle replacement RAYFIN Suspension - Brakes - Steering 4 12-03-2010 10:01 AM
'85 700r4 work in a 1990 k1500 Burnsumrubber305 Transmission - Rearend 15 01-09-2008 11:30 AM


All times are GMT -6. The time now is 03:26 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.