1992 chevy 1/2 ton (383 Stroker) won't rev! - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 12-10-2002, 06:51 PM
Registered User
 
Join Date: Dec 2002
Location: Blackfoot, ID
Posts: 8
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post 1992 chevy 1/2 ton (383 Stroker) won't rev!

We just finished (we thought) building a 383 for a 1992 chevy pick-up. everything is hooked up, valves a adjusted and timing is set. The motor runs good at idle and revs quikley to 2200 rpm but will not go any higher. What is the problem?
(Timing is at 0* we tried to advance but didn't help, fuel pump is good)

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 12-10-2002, 07:26 PM
BOBCRMAN@aol.com's Avatar
Member
 
Last photo:
Join Date: May 2002
Location: Holly, michigan
Posts: 8,117
Wiki Edits: 0

Thanks: 25
Thanked 266 Times in 249 Posts
Post

do you have the correct timing tab for the balancer you are using?, that small block should purr with 6-8 degrees initial timing with 36-38 total at about 3200 rpm, are the valves properly lashed?what carb?
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 12-10-2002, 08:41 PM
xtreme off-road's Avatar
Member
 
Last photo:
Join Date: Sep 2002
Location: North Bay, Ontario, Canada
Posts: 131
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

Are you using the stock TBI? And if you are, have you increased your fuel pressure? I have a 383 in my 1 ton and it took some playing around to keep the computer happy. <img src="graemlins/crash.gif" border="0" alt="[crash]" /> <img src="graemlins/evil.gif" border="0" alt="[evil]" />
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 07:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.