1993 Chev. Suburban 2wd 4L60E Problems - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 10-25-2009, 08:42 PM
Registered User
 
Join Date: Oct 2009
Location: Crossville, TN
Posts: 4
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
1993 Chev. Suburban 2wd 4L60E Problems

This is my first post here. I have visited alot and learned alot from it. So thanks to everyone in advance for info that I have taken and info that I will receive in the future.

My problem, I have a 1993 Chev. Suburban 2wd. I had trans rebuilt. Worked fine for 2 years. Motor went down so I rebuilt motor. Sub sat for 6 months. When I put the motor back in trans would not work right. Here is what it does, when cold it will shift through the gears great. After 5-10 min. it goes straight to 4th. Will not shift down. So I shift it manually. 1st, 2nd, 3rd, and so on. It will shift great that way. We thought it might be something electrical in the trans, so we changed everything. Still the same. Changed computers in sub. Still the same. We thought it might be losing pressure when it got hot, so I was going to take it out and rebuild it again. But before I could do that last week, the trans quit. Would not pull or anything. So I took it out and had it rebuilt. Found that the torque converter was out, and alot of metal inside. Put it back in last night. Same thing still happens. Did not change one thing. Somebody please help on this. There has got to be something I am over looking.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 10-25-2009, 09:54 PM
Crosley's Avatar
Hotrodders.com Moderator
 
Last wiki edit: T-350 rebuild tech
Last journal entry: Bar under the dash
Last photo:
Join Date: Nov 2002
Location: ... USA
Posts: 8,081
Wiki Edits: 1659

Thanks: 328
Thanked 99 Times in 95 Posts
truck72 .. welcome to Hotrodders.com

We do not use PLEASE HELP in thread titles here. There are some real sharp folks here that will help you without begging.

I would suggest the use of a device commonly known as a Shaffer Shifter to control this transmission on a test drive while the trans is warmed up where the shift problems show up.

this Shifter device is generally in a larger shop. Some shops may have a different brand of controller to remove the trans from the vehicle control systems.

If the isolated transmission still shifts to 4th gear when it should be in first gear electronically while OFF the vehicle computer system , the problem is inside the trans.

If the trans operates correctly on the stand alone controller .. the problem is in the vehicle system

__________________
Some people are like Slinkies... Not really good for anything, but they still bring a smile to your face when you push them down a flight of stairs.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 11-05-2009, 06:33 AM
Registered User
 
Join Date: Oct 2009
Location: Crossville, TN
Posts: 4
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
chevy sub 4l60e problem

Took it to a shop this week. Computer is trying to go into 4wd low. When it does this is when the trans is acting up. It is a 2wd. Any suggestions?
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
4l60e problem 93 suburban hecfrombx Transmission - Rearend 21 04-04-2009 07:40 AM
1993 Suburban Transmission Swap dlac1769 Electrical 1 10-30-2004 02:09 PM
1993 Suburban k1500 Transmission upgrade dlac1769 Transmission - Rearend 3 10-23-2004 07:26 AM
4L60E transmission problems BICHN69 Engine 1 08-14-2004 11:23 PM
4L60E shift problems 68vortec Electrical 0 07-10-2003 11:10 AM


All times are GMT -6. The time now is 02:22 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.