1995 Chevy k-2500 Specialty tech question??? - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 01-29-2010, 04:51 PM
rbp rbp is offline
Registered User
 
Join Date: Jul 2009
Location: Kirkland Washington
Posts: 22
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
1995 Chevy k-2500 Specialty tech question???

Hi dudes, I have a question regarding the symptoms of my transmission. I have a 1995 chevy k2500. About 8 months ago, I replaced the 2/3 shift solenoid (b) because it was faulty and got picked up by the computer (by the way I replaced both brand new from GM). The symptom was from the shifting from 2 to 3 sometimes it shifts without a problem, but sometimes it didn't shift. To make it shift, I turned off the truck, waited for a few seconds, and restarted it and it shifted without problems. The problem got corrected when I replaced the solenoids. Now it's doing it again. What can be causing this problem? One of my friends said the computer ECU and I said sticking valve. Any hints or ideas???

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 01-29-2010, 06:21 PM
Crosley's Avatar
Hotrodders.com Moderator
 
Last wiki edit: T-350 rebuild tech
Last journal entry: Bar under the dash
Last photo:
Join Date: Nov 2002
Location: ... USA
Posts: 8,057
Wiki Edits: 1659

Thanks: 314
Thanked 94 Times in 91 Posts
Quote:
Originally Posted by rbp
Hi dudes, I have a question regarding the symptoms of my transmission. I have a 1995 chevy k2500. About 8 months ago, I replaced the 2/3 shift solenoid (b) because it was faulty and got picked up by the computer (by the way I replaced both brand new from GM). The symptom was from the shifting from 2 to 3 sometimes it shifts without a problem, but sometimes it didn't shift. To make it shift, I turned off the truck, waited for a few seconds, and restarted it and it shifted without problems. The problem got corrected when I replaced the solenoids. Now it's doing it again. What can be causing this problem? One of my friends said the computer ECU and I said sticking valve. Any hints or ideas???
What is the mileage on this vehicle trans?

has it been rebuilt or only the repair you mention?

Has the PCM been scanned with a proper scanner (NOT code reader) that can read code history and watch live data stream as the vehicle is driven?
__________________
Some people are like Slinkies... Not really good for anything, but they still bring a smile to your face when you push them down a flight of stairs.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 01-29-2010, 06:57 PM
rbp rbp is offline
Registered User
 
Join Date: Jul 2009
Location: Kirkland Washington
Posts: 22
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
the tranny has around 50K the truck 305K! same engine same computer... and no I haven't scanned it. Started acting up just yesterday... I have problaby a long weekend ahead of me. But any ideas will be helpful before I start removing valve body, valves, sensors, computer and R&R of tranny! thanks for ya'll help!
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 01-29-2010, 08:56 PM
Crosley's Avatar
Hotrodders.com Moderator
 
Last wiki edit: T-350 rebuild tech
Last journal entry: Bar under the dash
Last photo:
Join Date: Nov 2002
Location: ... USA
Posts: 8,057
Wiki Edits: 1659

Thanks: 314
Thanked 94 Times in 91 Posts
Quote:
Originally Posted by rbp
the tranny has around 50K the truck 305K! same engine same computer... and no I haven't scanned it. Started acting up just yesterday... I have problaby a long weekend ahead of me. But any ideas will be helpful before I start removing valve body, valves, sensors, computer and R&R of tranny! thanks for ya'll help!
I gave you an idea to diagnose the problem. Scan the system as it operates in a live data stream. You watch what the PCM is commanding the trans to do and see If the trans responds correctly.

Why would you remove parts when you have no idea what or where to look? It is like a surgeon opening a human without a look see inside via x-ray or cat-scans to have an idea of where to look.

If the trans refuses to shift at certain times... then after you cycle the ignition key to off , then a re-start ... this resets the PCM. There may be a soft code set if the Check engine Lite was not illuminated.... the check engine lite indicates a hard DTC was set

The problem may not be inside the trans. Something that sets a code where the trans is affected does not have to be inside the trans.

You could have a charging - electrical system problem cause this
__________________
Some people are like Slinkies... Not really good for anything, but they still bring a smile to your face when you push them down a flight of stairs.
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
the history of chevy v8's savman1 Hotrodders' Lounge 43 03-02-2012 06:57 PM
1995 chevy 1500 4l60e stenichs Transmission - Rearend 2 05-10-2009 01:52 AM
Chevy 10 bolt front end question Magikal Transmission - Rearend 1 12-09-2007 01:00 PM
Chevy Inline six question 40chevy Engine 10 05-03-2006 04:16 PM
56' Chevy Rear Bumper Question maxie56 Body - Exterior 2 05-25-2005 09:11 AM


All times are GMT -6. The time now is 01:12 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.