Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - 1995 chevy s10 blazer 4x4 v6 trans problems
View Single Post
  #3 (permalink)  
Old 11-17-2007, 08:15 PM
Crosley's Avatar
Crosley Crosley is offline
Global Moderator
Last wiki edit: T-350 rebuild tech
Last journal entry: Morris update 03-22-2015
Last photo:
Join Date: Nov 2002
Location: ... USA
Posts: 8,672
Wiki Edits: 1659

Thanks: 632
Thanked 187 Times in 170 Posts

welcome to the HR board. I edited the thread title.

Please do not post a "HELP ME!" thread title. There are many experienced and/or professional fellows here. A proper thread title will get more responses.

I have a 1995 chevy s10 blazer 4x4 v6 vortec. I was pulling out of a parking lot and the transmission i assume jerked and i lost all forward gears so I put it in reverse and drove back to the parking lot. I sat there for a while and checked trans fluid while on and it was fine made sure it wasnt linkage. then i took the trans fuse out and it kicked into third gear only when it was in overdrive. It would not kick into first or second gear.

Mileage on this trans? Any recent repair or service work on the trans?

With the fuses installed into the fuse block;

Does the trans move forward in "OD" ? Does it move forward in "D". Move the shifter all the way to manual "1" to see if the trans moves forward.

Very odd the trans "kicked in" with the fuse out , yet would not move forward with the shifter in "OD or D" .... by "kicked in" ..., you do mean the trans engaged into gear?

Report back when you can . thanks

Dont worry how old you are... it is the mileage on your body that adds up.
Reply With Quote