1995 S 10 Blazer 4.3 Vortex - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 05-10-2008, 10:00 AM
Registered User
 
Join Date: May 2008
Location: california
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
1995 S 10 Blazer 4.3 Vortex

Hi every body I am a machinist by trade but New cars got by the butt!
lol I did a tune up plugs and wires and also new muffler from the yolk out.
And the muffler gets hot fast ? got any suggestion's

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 05-10-2008, 01:31 PM
poncho62's Avatar
Out of the Loop Moderator
 
Last wiki edit: Streetbeasts links
Last journal entry: at car show
Last photo:
Join Date: Oct 2003
Location: Hanover, Ontario, Canada
Age: 62
Posts: 16,881
Wiki Edits: 5

Thanks: 20
Thanked 254 Times in 207 Posts
welcome......Not sure that I understand the question, but you should probably ask it in the engine forum.
__________________
Ontario Rodders

Budget RVs
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 05-10-2008, 05:25 PM
Registered User
 
Join Date: May 2008
Location: california
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
1995 S10 Blazer4.3 v6 vortex

I changed water pump and thermostat, changed plugs and wires. put 2 shifting selanoids in also, Then i patch the muffler and the cheek engine light out, til the stuff i used harded like a cast on ur leg then it started missing and idleing funny from 1k to 750rpms and running real ruff at a idle only! Does anybody have a easy fix for me?

Thank you Poncho62 for ur in put.
BrettC49
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 05-10-2008, 06:51 PM
carsavvycook's Avatar
My 2 cents worth
 
Last photo:
Join Date: Sep 2007
Location: Lakeside, CA
Age: 57
Posts: 2,855
Wiki Edits: 3

Thanks: 2
Thanked 2 Times in 2 Posts
Check to make sure the rear plug wire on the passenger side is on the spark plug, and not jammed in between the plug and head. Don't ask me how I know this please. It is just easy to do because it is so hard to get to it in the first place.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1995 chevy s10 blazer 4x4 v6 trans problems SonnyFaust Transmission - Rearend 7 11-27-2007 06:56 AM
Brake lights switch oldsmo Electrical 4 10-19-2006 11:23 AM
wiring a v8 up in a s 10 blazer wolfinwv Electrical 5 01-22-2006 02:11 AM
Blazer S10 4.3 idles poorly bigjack Engine 1 03-30-2003 08:38 AM


All times are GMT -6. The time now is 07:06 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.