1996 Blazer electrical question - Page 2 - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #16 (permalink)  
Old 03-10-2013, 03:35 PM
T-bucket23's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Engine basic condition - how to check Last photo:
Join Date: Aug 2005
Location: Massachusetts
Age: 57
Posts: 5,362
Wiki Edits: 26

Thanks: 9
Thanked 145 Times in 128 Posts
Check to make sure the fans are not running after you shut the car off. A stuck fan relay can wreak havoc. Pulling fuses one at a time while monitoring an AMP meter in the battery line should help to start to pin the issue down. I have seen stuck relays on high draw items like fans, fuel pumps etc kill a battery in short order. I have also see rear window defrosters come on by themselves but this was on Ford Crown vics

    Advertisement
__________________
Artificial Intelligence is no match for Natural Stupidity



Chet
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1996 chevy blazer. Toddclary Electrical 4 10-27-2010 09:53 PM
1996 Blazer 4x4 brian berwick Suspension - Brakes - Steering 2 09-13-2009 12:22 PM
1996 chev blazer brian berwick Engine 3 08-29-2008 03:06 PM
1996 blazer fuel issues brian berwick Engine 1 08-18-2008 05:04 AM
What's the best Posi for a 1996 Blazer harold2 Transmission - Rearend 2 07-06-2007 09:10 AM


All times are GMT -6. The time now is 07:12 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.