1996 chev blazer - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-28-2008, 11:59 PM
brian berwick's Avatar
Registered User
 
Join Date: Jun 2006
Location: canada
Posts: 40
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
1996 chev blazer

I have had this a few weeks now the girl that had it before me put fuel filter on it 2 months or so ago ,plug wires,cap,runs good but to get it to start you have to put gas in throtle body to prime it it stalls sometimes when you go to back up .of if you turn a corner after being stopped at a light live in country havent been able to get to city to a shop its 4.3 v6 any ideas would be great thanks

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-29-2008, 02:15 PM
justold's Avatar
Registered User
 
Join Date: Sep 2003
Location: South Jersey
Age: 67
Posts: 192
Wiki Edits: 0

Thanks: 0
Thanked 4 Times in 4 Posts
I would check the pump relay . When you turn on the ignition the relay pulls in to prime the system , then when you build oil pressure the oil pressure switch closes and keeps the pump on .
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 08-29-2008, 03:03 PM
T-bucket23's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Engine basic condition - how to check Last photo:
Join Date: Aug 2005
Location: Massachusetts
Age: 57
Posts: 5,362
Wiki Edits: 26

Thanks: 9
Thanked 145 Times in 128 Posts
Quote:
Originally Posted by brian berwick
I have had this a few weeks now the girl that had it before me put fuel filter on it 2 months or so ago ,plug wires,cap,runs good but to get it to start you have to put gas in throtle body to prime it it stalls sometimes when you go to back up .of if you turn a corner after being stopped at a light live in country havent been able to get to city to a shop its 4.3 v6 any ideas would be great thanks
Fuel pump, or the filter is wrong or in backwards. Do you know if she had these issues before she had it "tuned up"

I would have a fuel pump presure test and volume test run to see what the issue is.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 08-29-2008, 03:06 PM
T-bucket23's Avatar
Hotrodders.com Moderator
 
Last wiki edit: Engine basic condition - how to check Last photo:
Join Date: Aug 2005
Location: Massachusetts
Age: 57
Posts: 5,362
Wiki Edits: 26

Thanks: 9
Thanked 145 Times in 128 Posts
Thinking back, we also had a similar issue with a bad Throttle position sensor once. If it thinks the throttle is depressed all the way it turns off the fuel. It doesnt explain you backing up issue but could explain the starting issue.
Just a thought

Chet
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1996 blazer fuel issues brian berwick Engine 1 08-18-2008 05:04 AM
What's the best Posi for a 1996 Blazer harold2 Transmission - Rearend 2 07-06-2007 09:10 AM
can I use an 80's blazer frame in my 54 Chev? In_Style Hotrodding Basics 13 09-13-2005 06:28 PM
Chev blazer tranny replacement tbirdscott Transmission - Rearend 5 06-03-2005 07:35 PM
1996 4 door s-10 blazer mural/pattern help ChrisMiddleron Body - Exterior 0 12-14-2003 01:34 AM


All times are GMT -6. The time now is 07:12 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.