1996 S-10 won't start - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 06-10-2009, 05:26 PM
Registered User
 
Join Date: May 2009
Location: Rochester NY
Posts: 5
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
1996 S-10 won't start

I have a 1996 Chevy S-10 with a 4.3 V6 & 4L60E transmission, I had the transmission replaced a week ago & today the truck will not start. I tried a new neutral safety switch but it didn't help. Could it be the ignition switch? How do I check it? Everything electrical works (headlights, horn, radio etc.) & a battery jump did not help. Any suggestions would be appreciated . When I turn the key there is no click or any noise. thanks bill

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 06-10-2009, 06:12 PM
Joe G's Avatar
Registered user
 
Last photo:
Join Date: Nov 2008
Location: St. Paul, MN
Posts: 586
Wiki Edits: 0

Thanks: 78
Thanked 30 Times in 29 Posts
Does your ignition key have a resistor in it like the one pictured below (Vehicle anti-theft system)? If it does, you may want to try the other key before you spend too much time or money. My Brother's '96 Caprice had a similar problem, and it turned out to be a blown resistor in the ignition key.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Basic of Basics" Welding - How do I repair body panels? Centerline Body - Exterior 33 03-31-2014 09:45 AM
1996 Vortec Engine Swap - need Help Adam Mclaughlin Engine 14 01-03-2005 09:56 AM
caprice wont start? Brian Morency Engine 8 08-24-2004 11:37 PM
please help..... annoying warm start problem 67cuda Engine 21 03-28-2003 05:44 AM
Hard Start Question Jim Weeks Engine 6 03-19-2002 04:30 AM


All times are GMT -6. The time now is 01:32 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.