1999 Mitsubishi Eclipse auto trans will not upshift - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 10-25-2012, 02:37 PM
Registered User
 
Join Date: Oct 2012
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
1999 Mitsubishi Eclipse auto trans will not upshift

Have a 1999 Mitsubishi eclipse that want come out of 1th gear it a automatic car......transmission has been replaced and all sensors has been replace and even the computer replace but still want come out of 1th gear......help!!!!

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 10-25-2012, 03:21 PM
Proud LOSER
 
Last photo:
Join Date: Mar 2008
Location: Ottawa
Posts: 1,842
Wiki Edits: 0

Thanks: 56
Thanked 265 Times in 230 Posts
Quote:
Originally Posted by countryboy37 View Post
Have a 1999 Mitsubishi eclipse that want come out of 1th gear it a automatic car......transmission has been replaced and all sensors has been replace and even the computer replace but still want come out of 1th gear......help!!!!
Any codes before you replaced the ecu? So what exactly does it do? Starts normal, put in drive, but it just won't up shift?
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 10-25-2012, 04:15 PM
LATECH's Avatar
Hotrodders.com Moderator
 

Last journal entry: Motor - vator
Last photo:
Join Date: Jul 2010
Location: Northeast Pennsylvania
Posts: 5,261
Wiki Edits: 0

Thanks: 215
Thanked 263 Times in 244 Posts
Quote:
Originally Posted by countryboy37 View Post
Have a 1999 Mitsubishi eclipse that want come out of 1th gear it a automatic car......transmission has been replaced and all sensors has been replace and even the computer replace but still want come out of 1th gear......help!!!!
Have the shift solenoids been checked?
Have you checked Line pressure?
Did you replace sensors with "new" ones ? Or did you put in used stuff.
AND what , if any codes were stored?
That car also has an automatic trans shift computer that is seperate from the ECU. It is in the center console.Last 99 mitsu I had with a similar shift problem needed the trans computer.
__________________
Fact is stranger than Fiction
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 10-26-2012, 07:35 AM
joshp83's Avatar
owner of Prices Garage
 
Last photo:
Join Date: Jun 2011
Location: west virginia
Age: 31
Posts: 318
Wiki Edits: 0

Thanks: 0
Thanked 23 Times in 23 Posts
i yours the chrysler 604 or the mitsu unit the chrysler has a suare pan on the bottom the mitsu has a pan on the side
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 10-27-2012, 02:09 PM
Registered User
 
Join Date: Oct 2012
Posts: 2
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
thks for the replys ....i was wrong with the year on the eclipse its a 95 model and all sensor has been replaced.....im trying to buy this car and the owner told me everything has been replace but im not sure if the tcm has been reprogramed or not.....if it has what else do i need to check.....thks
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 10-28-2012, 08:16 AM
LATECH's Avatar
Hotrodders.com Moderator
 

Last journal entry: Motor - vator
Last photo:
Join Date: Jul 2010
Location: Northeast Pennsylvania
Posts: 5,261
Wiki Edits: 0

Thanks: 215
Thanked 263 Times in 244 Posts
you need to find a good OBD 1 scanner that has jap software for mitsu.
Clear any codes (probably by unhooking battery, then attemp to drive it. Then scan the trans control module for codes , repair/diagnose from there

Guessing at it wont fix it.You need to get down and diagnose the issue.
Also you may want to perform a pinout test on the shift solenoids, you will need an EWD for that. Verify the signal from the TCM unit to the shift solenoids is also a must, so a solenoid state chart will be required to determine if the TCM is outputting correctly or at all.
Piece of cake.
BTW if the speedometr isnt working, that means the VSS may not be outputting, that will also cause a no upshift, most other faults will leave the trans in second gear by default.
__________________
Fact is stranger than Fiction
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1999 2 door 2.2 Cavalier auto to 5 speed swap what do I need fumplet Transmission - Rearend 4 11-30-2010 11:46 PM
Where is transmission filter located on 2001 Mitsubishi eclipse auto? jordan2011 Transmission - Rearend 7 09-24-2008 06:14 PM
2001 mitsubishi Eclipse A-Frame/Lower control arm bent PLEASE HELP!! jordan2011 Suspension - Brakes - Steering 6 08-15-2008 05:17 AM
mitsubishi eclipse chevy conversion opinianoman Engine 12 07-18-2003 02:46 PM


All times are GMT -6. The time now is 05:53 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.