2.5 chrysler - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 11-27-2008, 08:54 PM
swvalcon's Avatar
Member
 

Last journal entry: rust on lt body shell
Last photo:
Join Date: Oct 2004
Location: mn
Age: 64
Posts: 1,016
Wiki Edits: 0

Thanks: 0
Thanked 11 Times in 11 Posts
2.5 chrysler

any chrysler tecs on here? I've got a 98 sebering with a 2.5 v6 it sends up a code p300. miss fire I've replaced plugs, plug wires, cap & rotor,It still miss firers at idle and up to 2000rpm then seems to run fine. When you frist take of from a light it falls on its face big time for a bit then seems to clear up and go.At 70 mph it runs along just fine maybe a little low on power but no noticeable miss. ever run into this?

    Advertisement

Last edited by swvalcon; 11-28-2008 at 06:40 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 11-27-2008, 09:37 PM
carsavvycook's Avatar
My 2 cents worth
 
Last photo:
Join Date: Sep 2007
Location: Lakeside, CA
Age: 57
Posts: 2,855
Wiki Edits: 3

Thanks: 2
Thanked 2 Times in 2 Posts
What weight oil are you running?

IIRC it should use 5W30 oil. A thicker oil on start up will keep the lifters pumped up while cold.

My next step would be to check fuel pressure, and volume.

It could also be a false reading O'2 Senor, or dirty Mass Air Flow Sensor.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 11-28-2008, 06:44 AM
swvalcon's Avatar
Member
 

Last journal entry: rust on lt body shell
Last photo:
Join Date: Oct 2004
Location: mn
Age: 64
Posts: 1,016
Wiki Edits: 0

Thanks: 0
Thanked 11 Times in 11 Posts
my brothers scan tool shows o2 and mas air are fine. would a vacuum leak at intake cause this?
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 11-28-2008, 07:56 AM
carsavvycook's Avatar
My 2 cents worth
 
Last photo:
Join Date: Sep 2007
Location: Lakeside, CA
Age: 57
Posts: 2,855
Wiki Edits: 3

Thanks: 2
Thanked 2 Times in 2 Posts
Quote:
Originally Posted by swvalcon
my brothers scan tool shows o2 and mas air are fine. would a vacuum leak at intake cause this?
Yes it can, so can an exhaust leak prior to the O'2 sensor.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 11-28-2008, 11:23 AM
sbchevfreak's Avatar
Licenced Automotive Technician
 
Last photo:
Join Date: Feb 2004
Location: Land of big Easter eggs, Alberta
Age: 34
Posts: 1,604
Wiki Edits: 0

Thanks: 8
Thanked 9 Times in 9 Posts
These 2.5 v6 mitsu motors were known for distributors causing missfires and no starts, as well. IIRC from my time with Chrysler, they are a b1tch to change.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
fiero 2.5 to 2.5 swap tkas4x4 Engine 27 06-28-2011 05:07 PM
98 chrysler 2.5 v/6 swvalcon Hotrodders' Lounge 3 12-06-2006 11:41 AM
tail pipe expansion 2.25 to 2.5 spinn Engine 1 10-29-2004 11:58 AM
2004 Chrysler ME Four-Twelve Supercar fourbyfourblazer Hotrodders' Lounge 6 10-08-2004 09:23 AM
What is wrong with a chrysler 68newport383 Body - Exterior 23 02-11-2003 04:35 AM


All times are GMT -6. The time now is 12:23 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.