2000 chevy s10 2.2 not shifting - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 09-17-2011, 06:46 PM
Registered User
 
Join Date: Sep 2011
Location: florida
Posts: 7
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
2000 chevy s10 2.2 not shifting

i just replaced shift sensor a.....all gears work manually... but want shift like they are suppose to ,,,it want even change out manully by hand.... what do you think jon...im stressed about this 2000 chevy s10 2.2 l

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 09-17-2011, 06:57 PM
Crosley's Avatar
Hotrodders.com Moderator
 
Last wiki edit: T-350 rebuild tech
Last journal entry: Bar under the dash
Last photo:
Join Date: Nov 2002
Location: ... USA
Posts: 8,101
Wiki Edits: 1659

Thanks: 340
Thanked 102 Times in 98 Posts
welcome to Hotrodders.com

I edited the thread title to indicate what vehicle you are working on.

Mileage on the trans? Any recent repair or service work.

Does the speed-O function?

Do you have reverse gear?
__________________
Some people are like Slinkies... Not really good for anything, but they still bring a smile to your face when you push them down a flight of stairs.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 09-17-2011, 07:00 PM
Registered User
 
Join Date: Sep 2011
Location: florida
Posts: 7
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
all gears work they just want change automaticlly....yes have reverse...what is speed 0....rebuilt about 3 years ago
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 09-17-2011, 07:03 PM
Crosley's Avatar
Hotrodders.com Moderator
 
Last wiki edit: T-350 rebuild tech
Last journal entry: Bar under the dash
Last photo:
Join Date: Nov 2002
Location: ... USA
Posts: 8,101
Wiki Edits: 1659

Thanks: 340
Thanked 102 Times in 98 Posts
Quote:
Originally Posted by charles l
all gears work they just want change automaticlly....yes have reverse...what is speed 0

Speed-O is that little gauge that indicates road speed.

Is the check engine lite illuminated?
__________________
Some people are like Slinkies... Not really good for anything, but they still bring a smile to your face when you push them down a flight of stairs.
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 09-17-2011, 07:06 PM
Registered User
 
Join Date: Sep 2011
Location: florida
Posts: 7
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
speed o works hooked up to computer...po571 came up fixed that same ****yes engine light is on
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 09-17-2011, 08:32 PM
Registered User
 
Join Date: Sep 2011
Location: florida
Posts: 7
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
transmission...

dropped pan changed filter fluid shift sesors....put on computer code came up shift solinoid adone that 80.ooo miles but truck is babied.....im baffeled now and could use help...you can take off in all gears....reverse works speedometer works....it auto matic but just want shift at allcan any one give me some fresh ideas...please help....2000 chevy s10 2.2 l im new on here just trying to get advice....would really appriciate it....thanks
Reply With Quote Quick reply to this message
  #7 (permalink)  
Old 09-17-2011, 08:35 PM
Crosley's Avatar
Hotrodders.com Moderator
 
Last wiki edit: T-350 rebuild tech
Last journal entry: Bar under the dash
Last photo:
Join Date: Nov 2002
Location: ... USA
Posts: 8,101
Wiki Edits: 1659

Thanks: 340
Thanked 102 Times in 98 Posts
Charles , Please stop creating new threads for the same question.

I merged your recent post to this thread and dumped your double posts

Post your additional information in this thread so the members can see the complete discussion in the same thread
__________________
Some people are like Slinkies... Not really good for anything, but they still bring a smile to your face when you push them down a flight of stairs.
Reply With Quote Quick reply to this message
  #8 (permalink)  
Old 09-17-2011, 08:38 PM
Registered User
 
Join Date: Sep 2011
Location: florida
Posts: 7
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
sorry....

new to this just trying to get help my friend
Reply With Quote Quick reply to this message
  #9 (permalink)  
Old 09-17-2011, 08:53 PM
Registered User
 
Join Date: Sep 2011
Location: florida
Posts: 7
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
pcm

where is this located...at
Reply With Quote Quick reply to this message
  #10 (permalink)  
Old 09-18-2011, 07:52 AM
Crosley's Avatar
Hotrodders.com Moderator
 
Last wiki edit: T-350 rebuild tech
Last journal entry: Bar under the dash
Last photo:
Join Date: Nov 2002
Location: ... USA
Posts: 8,101
Wiki Edits: 1659

Thanks: 340
Thanked 102 Times in 98 Posts
Charles, you indicate the shift solenoids (2) were replaced.

The check engine is 'on' , now? Were the codes cleared out and they come back immediately and the check engine lite comes back on?

It would be a good idea to drive the truck with a proper scanner hooked up to view the live data stream. You watch for the PCM to see if it is commanding a shift or not. You can also test the trans manually with the scanner to see if it shifts as you manually tell it to. The live data stream also shows other sensor operations that affect the vehicle operation.

The speed-O functions per your post. In the dash, does the PRND321 indicator function correctly too?

It is also possible you damaged the wire harness when changing the shift solenoids. Often the clearance for pan removal is tight with the exhaust in the way on some vehicles. The connectors can break and your truck is 11 years old, unless the internal wire harness was replaced during the rebuild you mention.
__________________
Some people are like Slinkies... Not really good for anything, but they still bring a smile to your face when you push them down a flight of stairs.
Reply With Quote Quick reply to this message
  #11 (permalink)  
Old 09-18-2011, 12:47 PM
Registered User
 
Join Date: Sep 2011
Location: florida
Posts: 7
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
tranny

i drpped the pan today and put a test light on both sensor connectors...they have power there....also reset everything with computer....even undone the battery cable.....stil want shift but light stayed off....hooked back up tp computer....says shift sensor is stuck....just like before....any ideas before i go crazy.....lol
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 Chevy S10 shifting trouble adicus Transmission - Rearend 13 09-15-2011 08:47 PM
2000 Chevy S10 shifting trouble Mike22 Transmission - Rearend 6 01-02-2009 06:30 PM
2000 Jimmy with shifting problem (code P0753) rjdrw Transmission - Rearend 4 12-27-2006 05:47 AM
2000 Buick tranny shifting weird? frankenvette Engine 6 06-13-2006 07:28 PM
2000 Buick tranny shifting weird? frankenvette Transmission - Rearend 1 06-13-2006 04:10 PM


All times are GMT -6. The time now is 02:13 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.