Hot Rod Forum : Hotrodders Bulletin Board - View Single Post - 2001 cadillac deville 4T80E problems
View Single Post
  #2 (permalink)  
Old 01-26-2012, 02:52 PM
Crosley's Avatar
Crosley Crosley is offline
Hotrodders.com Moderator
 
Last wiki edit: T-350 rebuild tech
Last journal entry: Bar under the dash
Last photo:
Join Date: Nov 2002
Location: ... USA
Posts: 8,075
Wiki Edits: 1659

Thanks: 324
Thanked 97 Times in 94 Posts
Quote:
Originally Posted by sp_18902
I am working on my 2001 cadillac deville. I had a tcc problem. I replaced the tcc and the harness. everything worked out good. I had a leak in the side pan so i tore it back down and replaced the gasket. Then added 5 quarts of fluid and started the car. I noticed it pushed some fluid out the filler hole and then it would not go into gear, nor would it take fluid. I found the pump shaft twisted and broken. I have gotten another one but would like to know what caused this. If anyone could advise me on this i would appreciate it. I don't have alot of experience with automatic trannys. The transmission is a 4t80e.

sp_18902 , Welcome to Hotrodders.com. I edited the thread title to provide vehicle information in the subject.

Since you changed the torque converter and then developed a damaged input driving shaft to the pump, I would speculate that you did not have the torque converter properly installed when the trans was bolted back to the engine.

The pump may be damaged too.
__________________
Some people are like Slinkies... Not really good for anything, but they still bring a smile to your face when you push them down a flight of stairs.
Reply With Quote