2001 cadillac deville 4T80E problems - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 01-26-2012, 09:57 AM
Registered User
 
Join Date: Jan 2012
Posts: 1
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
2001 cadillac deville 4T80E problems

I am working on my 2001 cadillac deville. I had a tcc problem. I replaced the tcc and the harness. everything worked out good. I had a leak in the side pan so i tore it back down and replaced the gasket. Then added 5 quarts of fluid and started the car. I noticed it pushed some fluid out the filler hole and then it would not go into gear, nor would it take fluid. I found the pump shaft twisted and broken. I have gotten another one but would like to know what caused this. If anyone could advise me on this i would appreciate it. I don't have alot of experience with automatic trannys. The transmission is a 4t80e.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 01-26-2012, 02:52 PM
Crosley's Avatar
Hotrodders.com Moderator
 
Last wiki edit: T-350 rebuild tech
Last journal entry: Morris update 9-28-2014
Last photo:
Join Date: Nov 2002
Location: ... USA
Posts: 8,104
Wiki Edits: 1659

Thanks: 343
Thanked 103 Times in 99 Posts
Quote:
Originally Posted by sp_18902
I am working on my 2001 cadillac deville. I had a tcc problem. I replaced the tcc and the harness. everything worked out good. I had a leak in the side pan so i tore it back down and replaced the gasket. Then added 5 quarts of fluid and started the car. I noticed it pushed some fluid out the filler hole and then it would not go into gear, nor would it take fluid. I found the pump shaft twisted and broken. I have gotten another one but would like to know what caused this. If anyone could advise me on this i would appreciate it. I don't have alot of experience with automatic trannys. The transmission is a 4t80e.

sp_18902 , Welcome to Hotrodders.com. I edited the thread title to provide vehicle information in the subject.

Since you changed the torque converter and then developed a damaged input driving shaft to the pump, I would speculate that you did not have the torque converter properly installed when the trans was bolted back to the engine.

The pump may be damaged too.
__________________
Some people are like Slinkies... Not really good for anything, but they still bring a smile to your face when you push them down a flight of stairs.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 01-27-2012, 06:19 AM
tnsmith10's Avatar
when will it rain???
 
Last photo:
Join Date: Jul 2003
Location: where its very dry and dusty
Age: 43
Posts: 1,297
Wiki Edits: 0

Thanks: 0
Thanked 2 Times in 2 Posts
Quote:
Originally Posted by sp_18902
I am working on my 2001 cadillac deville. I had a tcc problem. I replaced the tcc and the harness. everything worked out good. I had a leak in the side pan so i tore it back down and replaced the gasket. Then added 5 quarts of fluid and started the car. I noticed it pushed some fluid out the filler hole and then it would not go into gear, nor would it take fluid. I found the pump shaft twisted and broken. I have gotten another one but would like to know what caused this. If anyone could advise me on this i would appreciate it. I don't have alot of experience with automatic trannys. The transmission is a 4t80e.
you put the studded bolt for the trans mount bracket in backwards. short end goes into the casting, not the long side. i did this once...
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cadillac 4T80E Transmission helvehammer Transmission - Rearend 1 01-20-2012 05:13 AM
4t80e Cadillac Trans Problem mike0969 Transmission - Rearend 1 05-21-2010 10:35 PM
4t80e Cadillac Transmission Problems? mile-hightoyz Transmission - Rearend 8 05-12-2008 09:15 PM
Cadillac 4T80E Trans Northstar John Transmission - Rearend 2 05-12-2008 09:02 PM
4t80e Cadillac Transmission Problems? will22 Transmission - Rearend 2 05-12-2008 08:24 PM


All times are GMT -6. The time now is 04:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.