2001 Eclipse problems - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 08-08-2008, 04:09 PM
Registered User
 
Join Date: Oct 2006
Location: Steelville, MO
Posts: 90
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
2001 Eclipse problems

I am in the process of purchasing a 2001 mitsubishi eclipse. It is a friend of mine that owns it, and they said the problem is that it is running, but misfiring, and it is getting bad MPG. They checked, and they said that the only problem they see, is the valve cover gasket is leaking oil down on the spark plugs. Would this cause the problem? I am getting the car for $2500. So I think it is well worth it. any advice would be greatly appreciated. thanks!

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 08-08-2008, 05:33 PM
richard stewart 3rd's Avatar
Registered User
 

Last journal entry: 351W rebuild
Last photo:
Join Date: Jan 2006
Location: tremont, pa.
Age: 69
Posts: 2,217
Wiki Edits: 0

Thanks: 13
Thanked 15 Times in 14 Posts
Hi Jordan2011,
I would either put new plugs in or clean up what's already in there, including the wires & cap & if it didn't stop missing then I would probably pass on it.
Rich
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 08-08-2008, 09:30 PM
Registered User
 
Last wiki edit: How to title a hot rod Last photo:
Join Date: Feb 2007
Location: West Virginia
Age: 24
Posts: 3,389
Wiki Edits: 8

Thanks: 14
Thanked 1 Time in 1 Post
Check and clean the pcv.

Shane
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trans Question on my 2001 Chevy Silverado albino2_wolf Transmission - Rearend 0 09-16-2007 07:30 PM
BBC stroker problems? rynophilia Engine 2 07-08-2003 04:20 PM
Holley Carb Problems.. Meangreen Engine 8 06-24-2003 08:00 AM
LT1 knocking problems gollygwagen Engine 0 04-23-2003 05:52 AM
What problems should I look for in a 400 sbc? stonedchihuahua Engine 8 11-05-2002 02:36 PM


All times are GMT -6. The time now is 10:38 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.