Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Transmission - Rearend (http://www.hotrodders.com/forum/transmission-rearend/)
-   -   2001 Malibu Transmission Surges (http://www.hotrodders.com/forum/2001-malibu-transmission-surges-228523.html)

caelis 01-18-2013 09:41 AM

2001 Malibu Transmission Surges
 
I have a 2001 Chevy Malibu with a 40T40E transmission. About 180 months ago the transmission started surging on the highway around 2000 rpms. I took it to a mechanic and they changed the fluid, with no affect. I changed the fuel filter it helped for about two months. I took it to a Trans shop and they rebuilt it and it worked OK for two months. I changed the TPS and it improved for two months. I cleaned the MAF and it improved for two months. It then dawned on me that the battery was disconnected during each of these fixes. Now when the transmission acts up, I disconnect the battery (about every two months). I would think I have some sort of bad sensor and disconnecting the battery resets the computer. Does anyone have any ideas?

LATECH 01-18-2013 05:11 PM

Possible software /adaption problem.
Did you check for a service bulletin for the symptom?
May need a flash update.


All times are GMT -6. The time now is 04:47 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.