2001 Ranger 2.5L low idle speed - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 06-27-2011, 10:07 AM
Registered User
 
Last photo:
Join Date: Dec 2010
Location: Charlotte,NC
Posts: 91
Wiki Edits: 0

Thanks: 18
Thanked 0 Times in 0 Posts
2001 Ranger 2.5L low idle speed

I thought I would check here to see if anyone recognizes this problem. My daily driver 2001 Ranger (2.5L, 2wd, manual) after sitting for about ten days now won't idle (cuts off) and has set no codes--- If you get it warmed up, the idle falls to a useless 400 rpm and after giving it throttle and letting the rpm's slowly drop the "running" quality does not seem good at around 1000 rpm -- It seems rough, but not really a true "miss" -- Truck has 110,000 easy miles and a possibly related issue is that I suspect the oil pressure switch is failing as the oil pressure gauge is occasionally erratic
Any help appreciated!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 06-27-2011, 10:13 AM
Member
 
Last wiki edit: Ford axle ratio codes
Last journal entry: Rear Suspension
Last photo:
Join Date: Aug 2005
Location: Prattsville
Posts: 6,268
Wiki Edits: 31

Thanks: 2
Thanked 41 Times in 40 Posts
Clean the idle air control. They periodacly need it.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 06-27-2011, 10:16 AM
How fast is fast enough?
 
Last photo:
Join Date: Jun 2005
Location: St. Louis, MO
Age: 28
Posts: 8,236
Wiki Edits: 0

Thanks: 12
Thanked 220 Times in 205 Posts
The oil gauge is bouncing because it is idling too low, clean the IAC as noted and run some fuel system cleaner through it and you shouldn't have any problems.
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 06-27-2011, 10:33 AM
Member
 
Last wiki edit: Ford axle ratio codes
Last journal entry: Rear Suspension
Last photo:
Join Date: Aug 2005
Location: Prattsville
Posts: 6,268
Wiki Edits: 31

Thanks: 2
Thanked 41 Times in 40 Posts
oil gauge on those fords is an idiot light. goes to 1/2 with 6 PSI of oil. failing senders are common but hurt nothing
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 06-27-2011, 10:14 PM
Registered User
 
Last photo:
Join Date: Dec 2010
Location: Charlotte,NC
Posts: 91
Wiki Edits: 0

Thanks: 18
Thanked 0 Times in 0 Posts
Thanks for the help! I already expected that the oil pressure "gauge" was really just on idiot light as I could not see any way just suppling a ground would allow a true analogue gauge to work
Reply With Quote Quick reply to this message
  #6 (permalink)  
Old 06-29-2011, 01:35 PM
Registered User
 
Last photo:
Join Date: Dec 2010
Location: Charlotte,NC
Posts: 91
Wiki Edits: 0

Thanks: 18
Thanked 0 Times in 0 Posts
Just to close this post: I replaced the IAC today ($37, 15 minutes) and my truck now idling just fine ---- THANKS AGAIN for the spot on correct advise!
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Idle issue - 96 ranger 406 bug Engine 3 03-15-2010 08:26 AM
2001 dodge ram 1500 v6-rough idle rookie builder Engine 14 04-24-2009 12:27 AM
89 Ranger Idle Problem keezyman Engine 8 03-10-2007 09:23 PM
1983 Ford Ranger won't idle 1957ford General Rodding Tech 3 04-25-2005 08:37 PM
what should my 2001 gmc k2500hd idle at? lostron33 Engine 7 09-19-2004 05:13 PM


All times are GMT -6. The time now is 08:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.