2002 Chevy Silverado 1500 random misfiring - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine> Modern Electronic Engines
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 02-02-2012, 07:57 AM
Registered User
 
Join Date: Feb 2011
Location: hogansville ga
Posts: 10
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
2002 Chevy Silverado 1500 random misfiring

Sorry, this isn't for my hot rod. I have a 2002 Chevy Silverado 1500 that is my daily driver while I work on my 82 El Camino. Was wondering if anyone has any ideas?

I have a 2002 Chevy Silverado 1500 2wd with the 4.8L. Recently the truck has been giving me a lot of problems. Right now it has a random misfire going on and it sounds like a electrical short in the spark plugs wire. Sometimes #1, or #6, or #7 but never in series and never all together. When it occurs you can hear a clicking noise coming from around the coil packs, and the truck looses almost all power and runs like crap. I have had two different well known shops in my area put it on diag machines. One told me that my spark plugs were bad so I changed them all out with brand new ones and it didn't help at all. The other told me I had a leak around the intake manifold. I do not, I did the windex test and not sucking in any air anywhere on the intake. I took it to a parts store and they tested my alternator and battery which both passed with flying colors.

Any one got any ideas?? I thinking MAF, coil packs, or electrical harness. Anyone else had similar problems and if so resolutions? I left any details out just let me know. Thanks in advance.

Richard

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 02-02-2012, 06:19 PM
LATECH's Avatar
Hotrodders.com Moderator
 

Last journal entry: Motor - vator
Last photo:
Join Date: Jul 2010
Location: Northeast Pennsylvania
Posts: 5,431
Wiki Edits: 0

Thanks: 230
Thanked 295 Times in 274 Posts
Moved to Modern Engine Electronics.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 02-02-2012, 06:21 PM
LATECH's Avatar
Hotrodders.com Moderator
 

Last journal entry: Motor - vator
Last photo:
Join Date: Jul 2010
Location: Northeast Pennsylvania
Posts: 5,431
Wiki Edits: 0

Thanks: 230
Thanked 295 Times in 274 Posts
Did anyone check the fuel pressure or integrity/ contamination?
Not to sure what a shorted spark plug wire sounds like. Or do you mean that it is knocking or something?
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 04-13-2012, 10:16 PM
dklong's Avatar
Member
 
Last photo:
Join Date: May 2002
Location: sussex nb canada
Age: 49
Posts: 250
Wiki Edits: 0

Thanks: 0
Thanked 2 Times in 2 Posts
I've seen afew of these engines with high mileage , have dirt or rust in the fuel rail , that plugs up the top of the injector . remove the fuel rail and clean the top of the injectors
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 05-15-2012, 07:50 PM
sbchevfreak's Avatar
Licenced Automotive Technician
 
Last photo:
Join Date: Feb 2004
Location: Land of big Easter eggs, Alberta
Age: 35
Posts: 1,609
Wiki Edits: 0

Thanks: 15
Thanked 9 Times in 9 Posts
Could need a crank angle sensor error relearn, this will cause weird random misfires.
Reply With Quote Quick reply to this message

Recent Modern Electronic Engines posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1999 chevy silverado 1500 4L60E transmission problems 4L60E help Transmission - Rearend 1 08-27-2011 08:22 PM
What transmission do I have? 1995 chevy 1500 silverado skulfreak Transmission - Rearend 1 08-13-2011 10:33 AM
2002 Silverado, 4L60e, No movement in any gear bigballar55 Transmission - Rearend 12 12-29-2010 09:01 AM
2002 chevy silverado nickman2002 Engine 7 03-16-2010 12:18 PM
Lift kits for 2002 chevy 1500 derrick3422 Suspension - Brakes - Steering 1 12-17-2005 08:31 PM


All times are GMT -6. The time now is 10:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.