2002 Ford Windstar - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 09-11-2011, 05:22 PM
KENMO's Avatar
St Louis Blues fan....
 
Last photo:
Join Date: May 2007
Location: Nova Scotia, Canada
Posts: 372
Wiki Edits: 0

Thanks: 2
Thanked 1 Time in 1 Post
2002 Ford Windstar

Asking for my Dad, so please be kind...

My Dad has a 2002 Ford Windstar with a 3.8L V6. Can anyone kindly let me know where the OSS sensor is located? He's getting a P0720 OBD2 code and it is indicating the OSS sensor needs replacing. He has previously replaced the TSS sensor and that was too easy to find...

Thanks kindly...

Ken

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 09-11-2011, 10:27 PM
willowbilly3's Avatar
Member
 

Last journal entry: Body mods
Last photo:
Join Date: Jun 2004
Location: Black Hills, South Dakota
Age: 61
Posts: 1,208
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Just because it flashes a code doesn't necessarily mean you are supposed to throw that part at it. It is just giving you a general area to diagnose.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 09-12-2011, 08:29 AM
tnsmith10's Avatar
when will it rain???
 
Last photo:
Join Date: Jul 2003
Location: where its very dry and dusty
Age: 43
Posts: 1,297
Wiki Edits: 0

Thanks: 0
Thanked 2 Times in 2 Posts
Quote:
Originally Posted by KENMO
Asking for my Dad, so please be kind...

My Dad has a 2002 Ford Windstar with a 3.8L V6. Can anyone kindly let me know where the OSS sensor is located? He's getting a P0720 OBD2 code and it is indicating the OSS sensor needs replacing. He has previously replaced the TSS sensor and that was too easy to find...

Thanks kindly...

Ken
the OSS is found on the main part of the case down about 1/2 way. its directly under the exhaust manifold on the firewall side.
even though i have seen those sensors fail but, with the explanation that the ISS (turbine sensor) has already been replaced already could lead to something else wrong. it could be a ground or pcm issue, a problem with the wiring harness or, it could be internal.
the best thing to do is remove the sensor and check with a DVOM, or take the vehicle to a transmission shop and have them drive it with a scan tool hooked up in data stream mode to verify OSS operation (or the lack there of).
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1995 Ford Windstar Front Subframe awbazar Suspension - Brakes - Steering 8 12-20-2010 05:38 AM
Ford Windstar rear door light... awbazar Electrical 4 12-06-2008 12:29 PM
Ford Windstar engine interchange jvanbu5132 Engine 4 10-05-2008 09:16 AM
2002 Ford Explorer. Skunk Engine 1 09-05-2005 09:49 PM
Help!! Ford Windstar Transmission Problems NAIRB Transmission - Rearend 0 05-11-2004 09:25 PM


All times are GMT -6. The time now is 06:32 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.