2004 vortec 5.3 water temp problems - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 05-13-2013, 01:13 PM
Registered User
 

Last journal entry: 81 regal swap project
Last photo:
Join Date: Apr 2010
Location: Spring Hill, KS
Posts: 20
Wiki Edits: 0

Thanks: 2
Thanked 0 Times in 0 Posts
2004 vortec 5.3 water temp problems

I got a 2004 z71 with the 5.3 vortec and whenever the outside temp is over about 70 my engine wants to jump around in temp. It usually runs just below 210 I'd guess about 195 or 200 but when it's 70 plus outside it will run up to about 220 which is pushin the safe zone and I'm not racin around and tearin it up. Just cruisin. On the highway whenever I head up a hill temp will rise then go back down to 210ish and in the city whenever I take off from a light or stop sign it will do the same. I just changed my oil today and there is no sign of anti freeze in it and nothing comes out of the exhaust and the coolant level has not changed... I've burped the cooling system to make sure all the air is out of it... Could it be just a thermostat or somethin more serious like a head problem or intake issue? Any help would be great. Thank you

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 05-13-2013, 05:25 PM
Registered User
 
Last photo:
Join Date: Apr 2007
Location: Seattle, Wa
Posts: 6,764
Wiki Edits: 0

Thanks: 4
Thanked 427 Times in 366 Posts
Quote:
Originally Posted by 4x4Chevy View Post
I got a 2004 z71 with the 5.3 vortec and whenever the outside temp is over about 70 my engine wants to jump around in temp. It usually runs just below 210 I'd guess about 195 or 200 but when it's 70 plus outside it will run up to about 220 which is pushin the safe zone and I'm not racin around and tearin it up. Just cruisin. On the highway whenever I head up a hill temp will rise then go back down to 210ish and in the city whenever I take off from a light or stop sign it will do the same. I just changed my oil today and there is no sign of anti freeze in it and nothing comes out of the exhaust and the coolant level has not changed... I've burped the cooling system to make sure all the air is out of it... Could it be just a thermostat or somethin more serious like a head problem or intake issue? Any help would be great. Thank you
More likely the radiator no longer moves enough coolant through the core, it's just crudded up with the stuff that collects in old cooling systems. It has Dexcool in it, this will be messy to fix. Probably the radiator will have to be replaced. All traces of Dexcool throughly flushed from the engine, heater core and all lines. Once clean you can go back to a mixture of Prestone and distilled or de-ionized water.

Bogie
Reply With Quote Quick reply to this message
The Following User Says Thank You to oldbogie For This Useful Post:
4x4Chevy (05-29-2013)
  #3 (permalink)  
Old 05-14-2013, 10:13 AM
Registered User
 

Last journal entry: 81 regal swap project
Last photo:
Join Date: Apr 2010
Location: Spring Hill, KS
Posts: 20
Wiki Edits: 0

Thanks: 2
Thanked 0 Times in 0 Posts
I am gonna try that. I never would have thought about that thank you!
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 05-29-2013, 06:58 PM
Registered User
 

Last journal entry: 81 regal swap project
Last photo:
Join Date: Apr 2010
Location: Spring Hill, KS
Posts: 20
Wiki Edits: 0

Thanks: 2
Thanked 0 Times in 0 Posts
That worked out great! Thank you for the advice
Reply With Quote Quick reply to this message

Tags
cooling, head, intake, temperature, thermostat

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
water temp tylerrosario1234 Engine 3 07-26-2011 12:27 PM
2004 chevy truck torque converter problems? cabledawg22000 Transmission - Rearend 4 11-16-2009 02:23 PM
water temp on sbc zephyrc Engine 17 02-18-2007 10:34 AM
Water temp varies?? Mudstomper Engine 5 03-12-2003 04:18 PM
Water temp. Jeff Christenson Engine 9 02-20-2003 07:44 PM


All times are GMT -6. The time now is 02:12 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.