2005 Dodge 2500 5.7 Hemi - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 05-11-2011, 02:31 PM
Registered User
 
Join Date: May 2010
Location: colonial heights va
Posts: 12
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
2005 Dodge 2500 5.7 Hemi

After driving for 30-40 minutes and let sit for 20 min. it will not start until engine bay cools completely. Have changed crankshaft sensor(got code) and computer. Also, after finally restarting truck it will momentarily cut out and lose cruise control and overdrive. If sits till next day everything is fine and after driving 45 minutes the whole process starts again. If going 65 mph and truck starts this, sometimes truck will cut off for 2-3 seconds and come back on by itself. HELP!!! PLEASE!!!! Thanks in advance , Jumm

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 05-18-2011, 04:09 PM
Registered User
 
Join Date: May 2010
Location: colonial heights va
Posts: 12
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Check for mice some where along your wiring harness.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 05-19-2011, 03:20 PM
vicrod's Avatar
life is a ride
 

Last journal entry: 2014
Last photo:
Join Date: Nov 2005
Location: Telford, PA
Age: 72
Posts: 1,361
Wiki Edits: 0

Thanks: 0
Thanked 63 Times in 59 Posts
I would check the fuel system. Clogged filter, bad pump, bad regulator, pinched hose.
Install a pressure gauge on the fuel rail test port and run the hose into the cab.
If the fuel pressure is OK you may need to go to a dealer for analysis of the problem. Sometimes the dealer can find problems that regular shops cannot.

vicod
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 Dodge Durango remote starter kill over ride labreejr Electrical 6 10-25-2010 08:27 PM
Dodge Ram 2500 concerns before purchase kadi Hotrodders' Lounge 9 09-26-2008 04:47 PM
HELP? buying a dodge 2500 van (year: 2000) jojo99 Hotrodding Basics 15 06-10-2008 04:25 PM
EGR Valve 2005 Dodge Magnum 5.7 cuda66 Engine 4 05-14-2007 07:26 PM
Need info on 1998 Dodge 2500 p/u oldscout Transmission - Rearend 1 06-05-2003 07:26 PM


All times are GMT -6. The time now is 07:12 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.