2005 Silverado 4x4 acting up - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Transmission - Rearend
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 12-29-2010, 11:28 PM
Registered User
 
Join Date: May 2008
Location: Detroit
Posts: 105
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
2005 Silverado 4x4 acting up

Hi guys,
I just got a 2005 Silverado with a intermittent 4x4 issue.
It only will engage into 4x4 once in a while. No I was reading that this trucks have issues with water getting into the electrical connectors. Can anyone confirm that? Also were can I find a wiring diagram for this 4x4 part of the truck so I can identify what im looking at?

Thanks!

Tomi

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 01-01-2011, 09:50 AM
Crosley's Avatar
Hotrodders.com Moderator
 
Last wiki edit: T-350 rebuild tech
Last journal entry: Bar under the dash
Last photo:
Join Date: Nov 2002
Location: ... USA
Posts: 8,057
Wiki Edits: 1659

Thanks: 314
Thanked 94 Times in 91 Posts
bounce this back up.

corrosion in connections happens... that is easy to check first
__________________
Some people are like Slinkies... Not really good for anything, but they still bring a smile to your face when you push them down a flight of stairs.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 01-02-2011, 08:20 PM
Registered User
 
Join Date: May 2008
Location: Detroit
Posts: 105
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Ok, I finally got back on that truck. Right now the 4x4 works. It shifts from 2wd to 4x4 no problem but it makes a pretty good "KLONG" when it shifts. Is that normal or does that indicate a bend shift fork or any other mechanical issue? All my trucks are old and you have to pull the big *** lever to put them into 4x4 so Im missing some experience here!

Thanks for your help!

Tomi
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 01-02-2011, 10:03 PM
Registered User
 
Join Date: Dec 2010
Location: El Paso, TX
Posts: 11
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
push-button 4x4

I can't speak from direct experience but my buddy has gone through 3 tranfers because of the push button 4x4. Once the connector got wet it wouldn't shift back into 2wd. That may not be the exact problem you're having but it's just food for thought.
Reply With Quote Quick reply to this message

Recent Transmission - Rearend posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
alternator acting up? or what? KoTT Engine 21 08-11-2009 05:26 PM
C6 acting up. LOWbutnotSLOW Transmission - Rearend 8 07-14-2009 07:07 PM
Just a too old kid acting way too young! KevinM Introduce Yourself 3 06-24-2008 11:16 PM
350 acting up :( PLEASE HELP! purple1967camaro Engine 3 06-19-2004 07:41 PM
TH-350 trans acting up Old School Nut Transmission - Rearend 14 12-10-2003 04:43 PM


All times are GMT -6. The time now is 03:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.