2009 ford escape - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 09-09-2013, 07:54 PM
Registered User
 
Join Date: Dec 2010
Location: florida
Posts: 24
Wiki Edits: 0

Thanks: 2
Thanked 0 Times in 0 Posts
2009 ford escape

engine miss. changed coils due to error codes, cleaned maf sensor, going to tps next and maybe idle air. still getting 22 mpg. any suggestions for the misfire I am getting? coders do not indicate coils or plugs. plugs also changed.

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 09-09-2013, 08:00 PM
LATECH's Avatar
Hotrodders.com Moderator
 

Last journal entry: Motor - vator
Last photo:
Join Date: Jul 2010
Location: Northeast Pennsylvania
Posts: 5,436
Wiki Edits: 0

Thanks: 230
Thanked 296 Times in 275 Posts
So you are getting misfire codes?
__________________
Fact is stranger than Fiction
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 09-11-2013, 09:50 PM
dklong's Avatar
Member
 
Last photo:
Join Date: May 2002
Location: sussex nb canada
Age: 49
Posts: 250
Wiki Edits: 0

Thanks: 0
Thanked 2 Times in 2 Posts
newbie you have to watch out on those 3.0 l escapes if you took off all 3 igniton coils, people are getting #4 and #6 coil connectors hooked up wrong, the wire harness for the coils lays over the valve cover , not along the edge of the cover, with it going along the edge of the valve cover #6 coil plug in lays beside #4 coil and the same with #6 coil is beside #4 coil plug
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
'03 escape fwd axle nut.. delawarebill Suspension - Brakes - Steering 4 12-22-2012 01:30 PM
wear spot in carpet below foot rest Ford Escape Duntov Interior 2 09-03-2010 01:01 PM
Back to the 50's 2009 RODDER18 Hotrodders' Lounge 9 06-22-2009 01:02 AM


All times are GMT -6. The time now is 06:31 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.