300h.p. 350sbc - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 10-18-2003, 08:35 PM
Coleman396's Avatar
Member
 
Join Date: May 2003
Location: British Columbia Canada
Posts: 71
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
300h.p. 350sbc

Hello Chevy fans. I just stumbled across a 1969 350ci from a Chevy Caprice. It is a 300 horse model! Can anyone tell me the specs for this engine. I believe the heads are the 041 castings and according to the owner it has a steel forged crank. Does this sound right? I am also wondering what the factory compression ratio would be. Is this a valuable engine? It is all stock and all complete from the pan to the air cleaner. Thanks a bunch!

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 10-18-2003, 11:23 PM
DoubleVision's Avatar
Not Considered a Senior Member
 
Last photo:
Join Date: Oct 2002
Location: Heart Of Dixie
Age: 40
Posts: 10,654
Wiki Edits: 0

Thanks: 15
Thanked 58 Times in 55 Posts
Quite a good find indeed. these had the 041 castings with 1.94 1.50 valves 64cc chambers, 10:1 compression, a cast iron intake with Quadrajet on the top, and if I remember correctly the one I had came with a cast iron crank, but it`s been so long ago I really can`t recall, look at the cranks parting line, if it`s wide it`s forged, if it`s thin it`s cast. these blocks are also sought after, there somewhat meatier than later blocks.
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 10-19-2003, 08:29 AM
Coleman396's Avatar
Member
 
Join Date: May 2003
Location: British Columbia Canada
Posts: 71
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Thanks for the reply Doublevision. I cannot see the crank end yet because the engine is installed partialy anyway.
I think maybe I should just but it and hope for the best. The Mortec site tells me it could be a two or a four bolt main so I guess we will wait and see. Have a great day!
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 11:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.