302 Ford, blue grommet module problem - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Electrical
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 10-30-2011, 11:07 AM
Registered User
 
Join Date: Oct 2011
Location: Texas
Posts: 6
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
302 Ford, blue grommet module problem

I have power to both sides of the coil with a test light. New Coil, New Module, AND NEW COIL WIRE. but no spark coming from coil wire using a clamp on plug tester. Need ideas, thanks

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 10-30-2011, 12:21 PM
willowbilly3's Avatar
Member
 

Last journal entry: Body mods
Last photo:
Join Date: Jun 2004
Location: Black Hills, South Dakota
Age: 61
Posts: 1,208
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
With a test light on the negative side of the coil, have someone crank the engine and see if the light pulses. If not you may have a bad pickup coil in the dist.
On the modules, I have never found any aftermarket ones to be of the same quality as the OEM. I used to hoard original Motorcraft blue grommet modules from junk cars. Until I discover the GM modules are easy to convert and work better. I'm running a GM module, Duraspark II dist and the coil from a 90s EFI 5.8. It's been flawless for several years.
Reply With Quote Quick reply to this message

Recent Electrical posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
fuel pressure problem - holley blue pump & reg stratt134 Engine 19 04-12-2013 03:44 PM
Blue Oval Ford Nuts!!?? full pull bob Engine 9 11-11-2008 06:26 PM
Blue prints 32 ford 5 window coupe fosriver Body - Exterior 1 01-31-2006 10:14 AM
Which HEI module for my Ford probe GT penekusu Introduce Yourself 2 01-24-2006 10:42 PM
ABS module problem on a 97 F150 4x4 jmhollis Suspension - Brakes - Steering 1 09-03-2005 10:53 PM


All times are GMT -6. The time now is 01:42 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.