Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Hotrodding Basics (http://www.hotrodders.com/forum/hotrodding-basics/)
-   -   302 is out. What next? (http://www.hotrodders.com/forum/302-out-what-next-227753.html)

kaw550 12-30-2012 05:26 PM

302 is out. What next?
 
I took my engine out to replace a leaking freeze plug. I am not sure if I should just replace the plugs and reinstall or if I should open everything up and inspect or replace.

The engine ran fine. I found a tag showing it was remanufactured but I have no idea how long ago or how many miles have been put on it. The casting numbers show that is is a '68.

I have already resealed the intake, valve covers,oil pan and replaced the rear main seal.

Should I be looking at the bearing, chain and bores or should I just put it back in? I am not really looking to spend money but it is out....


What are the weak links in a 302?

LATECH 12-30-2012 06:24 PM

It ran good, leave it be. Put the freeze (welch) plugs in it and forget it.
Dont overthink it and fake yourself out.:cool:

Torque454 12-30-2012 06:33 PM

id replace the timing chain atleast. On my 302 I'm planning to replace the bearings and oil pump in mine (althought it knocks on startup) and the timing chain as well as a cam (since I tow, figured a marine or RV cam would be good to do while its out and apart) and headers and all new gaskets and seals, including valve seals. I dont plan to pull the heads or do anything to the bores/pistons/rings, but that may change after I do a compression test.

Richiehd 12-30-2012 06:53 PM

You are replacing ALL the freeze plugs with brass ones I hope. Flush the sludge and rust out of that block with a hose when you have those old ones out.

cobalt327 12-30-2012 10:06 PM

Quote:

Originally Posted by kaw550 (Post 1628792)
I took my engine out to replace a leaking freeze plug. I am not sure if I should just replace the plugs and reinstall or if I should open everything up and inspect or replace.

The engine ran fine. I found a tag showing it was remanufactured but I have no idea how long ago or how many miles have been put on it. The casting numbers show that is is a '68.

I have already resealed the intake, valve covers,oil pan and replaced the rear main seal.

Should I be looking at the bearing, chain and bores or should I just put it back in? I am not really looking to spend money but it is out....


What are the weak links in a 302?

As said, replace ALL the freeze plugs. I have seen freeze plugs that looked OK that were basically a paint layer away from leaking. Take an awl and poke on a few that weren't yet replaced and you'll probably see what I mean.

Other than that, I would button it back up and reinstall it.


All times are GMT -6. The time now is 05:19 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.