305 carburetor - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 11-02-2002, 05:12 AM
beetle9's Avatar
Member
 
Last photo:
Join Date: Jan 2002
Location: mich
Posts: 104
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Question 305 carburetor

How much is too much? Have a 305 w/400 turbo with mild cam and headers, otherwise stock. Have a 750cfm elelbrock, but I'm afraid it would be too much. I'm thinking around 600cfm. Would this also be too much? Give me your opinion. thanks

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 11-02-2002, 05:29 AM
dmorris1200's Avatar
doesn't play well with others
 
Last photo:
Join Date: Feb 2002
Location: Maine
Age: 49
Posts: 1,834
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

Oh god not another 'how much carb' question . This one always gets the masses going <img src="graemlins/boxing.gif" border="0" alt="[boxing]" /> . I would definately go with the 600cfm range and vacuum secondaries. Now this doesn't mean you couldn't stick a 750 on her but with a 600 you'll get better fuel economy, better off idle response, and in my opinion better performance on a mostly stock 305ci engine. I'm running a 670cfm Street Avenger on my 302 with .471 lift cam and performer manifold, runs great.


[ November 02, 2002: Message edited by: dmorris1200 ]</p>
__________________
BUILT FORD TOUGH
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 11-02-2002, 05:38 AM
dmorris1200's Avatar
doesn't play well with others
 
Last photo:
Join Date: Feb 2002
Location: Maine
Age: 49
Posts: 1,834
Wiki Edits: 0

Thanks: 0
Thanked 0 Times in 0 Posts
Post

Well I tried to post the picture from my photo album of the 670 carb on my engine but it didn't work. Maybe I didn't do the link right.
__________________
BUILT FORD TOUGH
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 06:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.