305 and Edelbrock 1406 carb - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 02-17-2013, 04:14 PM
Registered User
 
Last photo:
Join Date: Dec 2012
Posts: 6
Wiki Edits: 0

Thanks: 1
Thanked 0 Times in 0 Posts
305 and Edelbrock 1406 carb

I need the collective assistance of the carburater gurus ....ii have an unusual problem with the engine and carb combination above. With the motor at operating temp and trans in neutral, motor seems to jump in rpm as throttle is advanced. While SLOWLY opening linkage from idle the engine will SLOWLY increase rpm...then about 1/4 inch off idle (no tach) the engine seems to jump up as if it suddenly gets a surge of gas. This is not noticable under load, but im sure its happening while driving as well. Already checked for vaccum leak and manifold leaks so its not that...just cant figure out the surge !

Any ideas ??????

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 02-17-2013, 04:22 PM
F-BIRD'88's Avatar
Yada Yada Yada
 
Last photo:
Join Date: Oct 2005
Location: Ontario, Canada
Posts: 9,156
Wiki Edits: 0

Thanks: 5
Thanked 380 Times in 374 Posts
Check for smooth consistant progressive action of the centrifical advance system.
It may be sticking and or not returning to base timing at idle.
A common issue with Chinesium distributors or warn OEM.
The very lightest weight/tension distributor advance springs from typical timing curve kits tend to give inconsistent advance action.

Be sure the advance weights are not hitting the bottom of the distributor rotor.

I avoid using two light springs. Just too light and floppy. 1 light and 1 medium is better.
Reply With Quote Quick reply to this message

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Edelbrock 1406 carb hard to start when hot 64Eldorado Engine 3 07-25-2011 11:06 AM
Another edelbrock 1406 carb question 99 to Life Engine 9 06-28-2011 04:32 PM
1406 edelbrock carb help hddave1 Hotrodding Basics 4 04-30-2011 01:44 PM
1406 edelbrock carb electric chock hook-up mferris72 Engine 1 09-03-2004 06:41 PM
edelbrock carb 1406 or 1411? MopaRV Engine 7 07-30-2003 01:07 AM


All times are GMT -6. The time now is 08:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.