Hot Rod Forum : Hotrodders Bulletin Board

Hot Rod Forum : Hotrodders Bulletin Board (http://www.hotrodders.com/forum/)
-   Engine (http://www.hotrodders.com/forum/engine/)
-   -   318 Surging, stalling (http://www.hotrodders.com/forum/318-surging-stalling-153126.html)

Echofive 02-10-2009 09:20 PM

318 Surging, stalling
 
Hello,

I have a 1989 Dodge B-250 Van, it used to run great until recently when it started running poorly in the cold (30F) early mornings. Sometimes it idles fine and just stalls, doesnt choke or sputter, just shuts off. If I keep the RPM"s up it stays running. in the mornings I have to pretty much floor it to get it moving, the motor seems to backfire(exhaust gets deeper), sputter for about 4 or 5 seconds and doesnt really make the van move then it kicks in and runs like it should at WOT. My check engine light doesnt come on, but a Check EGR light has been on for I don't know how long. Anyone know if this can throw a code that I could read? I have replaced the Throttle posisition sensor as well as the EGR valve which I had to buy from the Dodge dealership, because the ones from Autozone and Kragen wouldn't fit correctly. The EGR light remains on even after pulling the battery cable for 10 minutes. Is that enough? Also if I start the motor with the MAP sensor unplugged it runs exactly the same as it does w/ it plugged in. It just idles fine for a few seconds, then start changing RPM,s sometimes dropping to about 500 or so, maybe less, it gets really close to dieing, then comes back upto about 1000, then levels out, then sometimes just dies. Could this be the MAP sensor? I tested for 5v at the A and C points and watched it drop as my rpms came up then, the voltage came back up to between 4.5 - 4.90v.

Thanks for any help.

Kyle

sunsetdart 02-11-2009 05:34 AM

Kyle.....sounds more like the O-2 sensor. When idling is affected it is usually in fuel flow. The motor seems to be getting the wrong reading in just how much fuel is needed and then is adjusting according to how much oxygen is needed.

Echofive 02-11-2009 06:19 AM

O2 Sensor
 
Thanks for your input, I kinda of thought about that too, but wasnt sure.. I'll test it as soon as I get home from work, and let everyone know.

Thanks


All times are GMT -6. The time now is 11:40 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.