350 engine stalls - Hot Rod Forum : Hotrodders Bulletin Board
Hotrodders.com -- Hot Rod Forum



Register FAQ Search Today's Posts Unanswered Posts Auto Escrow Insurance Auto Loans
Hot Rod Forum : Hotrodders Bulletin Board > Tech Help> Engine
User Name
Password
lost password?   |   register now

Reply
 
LinkBack Thread Tools
  #1 (permalink)  
Old 02-26-2013, 09:13 PM
Registered User
 
Join Date: Feb 2013
Posts: 18
Wiki Edits: 0

Thanks: 27
Thanked 0 Times in 0 Posts
350 engine stalls

today,after driving my 84 monte carlo 350 engine aroung the neighbored after 5 min it stalls at a redlight as i started pressing the brakes cranks rite back up and does it again when i press on brakes or let off of gas what can it be FUEL PUMP,FUEL FILTER, VACUUMN PROBLEM,OR CARB
IT HAS
edelbrock carb 1406
edelbrock pro series intake
factory cam im assuming
350 sb
PLEASE HELP!!!!

    Advertisement
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 02-27-2013, 12:18 AM
dub's Avatar
dub dub is offline
Registered User
 

Last journal entry: Time to drive..
Last photo:
Join Date: Jun 2012
Posts: 114
Wiki Edits: 0

Thanks: 3
Thanked 3 Times in 3 Posts
It dies after hard braking?
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 02-27-2013, 06:22 AM
Registered User
 
Join Date: Feb 2013
Posts: 18
Wiki Edits: 0

Thanks: 27
Thanked 0 Times in 0 Posts
yes it dies after hard braking
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 02-27-2013, 11:59 AM
bigdog7373's Avatar
Of course it's fast
 
Last photo:
Join Date: May 2010
Location: florida
Posts: 2,670
Wiki Edits: 0

Thanks: 13
Thanked 49 Times in 49 Posts
Check your other thread. Lots of responses. Someone delete this double post.
Reply With Quote Quick reply to this message
The Following User Says Thank You to bigdog7373 For This Useful Post:
liljoe1996miller@aol (02-28-2013)
  #5 (permalink)  
Old 02-28-2013, 09:25 AM
Registered User
 
Join Date: Jun 2012
Posts: 128
Wiki Edits: 0

Thanks: 0
Thanked 7 Times in 7 Posts
could be your brake booster, unhook vacuum from booster and plug the vacuum off, try a hard braking situation, you wont have power brakes while doing this. if it still stalls its probably a carb situation, perhaps float level or bad needle and seat.
Reply With Quote Quick reply to this message
The Following User Says Thank You to prumora1 For This Useful Post:
liljoe1996miller@aol (02-28-2013)
  #6 (permalink)  
Old 02-28-2013, 09:49 AM
bigdog7373's Avatar
Of course it's fast
 
Last photo:
Join Date: May 2010
Location: florida
Posts: 2,670
Wiki Edits: 0

Thanks: 13
Thanked 49 Times in 49 Posts
Quote:
Originally Posted by prumora1 View Post
could be your brake booster, unhook vacuum from booster and plug the vacuum off, try a hard braking situation, you wont have power brakes while doing this. if it still stalls its probably a carb situation, perhaps float level or bad needle and seat.
That's so dangerous. Please don't do this on a road or anywhere near people. Your power break system is designed to work with vacuum from the engine. Without the booster working the pedal effort needed to stop the car will be very high and you will need probably twice the distance or more to stop the car. All you have to do is let the car idle and press the brake and see if it changes the idle, no need to drive it.
Reply With Quote Quick reply to this message
The Following User Says Thank You to bigdog7373 For This Useful Post:
liljoe1996miller@aol (02-28-2013)
  #7 (permalink)  
Old 02-28-2013, 12:34 PM
hcompton's Avatar
Old & Furious
 
Join Date: Oct 2012
Location: MD
Age: 42
Posts: 1,074
Wiki Edits: 0

Thanks: 6
Thanked 90 Times in 87 Posts
Its not vacum anyway its fuel in the float bowl is low and under hard braking it fails. Can also be casued by too much fuel pressure flooding the engine with fuel and making it sputter out. Many cars do this wil edel carbs and no regulator hooked up. This carb needs really close to its 5psi ideal pressure.
Reply With Quote Quick reply to this message
The Following User Says Thank You to hcompton For This Useful Post:
liljoe1996miller@aol (02-28-2013)

Recent Engine posts with photos

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Hot Rod Forum : Hotrodders Bulletin Board forums, you must first register.
Please enter your desired user name (usually not your first and last name), your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
350 engine stalls liljoe1996miller@aol Hotrodding Basics 17 03-01-2013 10:18 PM
350 Trans Issue, Stalls engine in Reverse mseifried Transmission - Rearend 12 04-14-2009 02:52 PM
engine stalls say10tatoo Transmission - Rearend 2 08-14-2005 01:00 PM
Engine stalls Jessy James Engine 20 10-26-2004 03:59 PM
chevy 350 stalls stape Engine 8 12-07-2003 01:16 PM


All times are GMT -6. The time now is 04:42 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0 PL2
Copyright Hotrodders.com 1999 - 2012. All Rights Reserved.